Does not create a config.ini

Help
Matt
2004-03-01
2004-04-28
  • Matt

    Matt - 2004-03-01

    Nagios is up and running using authentication.

    installed to:  /usr/local/nagios/share

    I put the NawUi into /usr/local/nagios/share/nawui so I would not have to double-authenticate.

    My webserver runs as httpd:httpd.  The entire /usr/local/nagios tree is chmod to nagios:httpd and -rw by group.  The nagios user is a member of the httpd group. 

    When I access /nagios/nawui I get the Configuration Page, since includes/config.ini does not exist yet.  But it will not ever create this file!

    I'm sure I'm doing something stupid...   Help!

    Thanks,
    Matt

     
    • Dylan Thurston

      Dylan Thurston - 2004-03-18

      I ran into this same problem and after some research i got it to work

      the problem is in the php config. in your php.ini file you need to make sure that the register_globals setting in the php.ini file is set to on.

      Example:

      register_globals = On

      after you make the change in php.ini you will need to restart your web server. then try to the config nawui via the setup.php

       
    • Kip

      Kip - 2004-04-28

      Howdy,

      I have the same problem, Did you get this fixed?
      php is working great, I have register_global=On,

      but when I hit the setup button after entering the initial setup for the first time, I get the screen redrawn, it removes all my entry's putting them back to what it was, and then nother.

      I'm setting this up on a solaris system. The apache logs give me no errors, and of course no config.ini
      after hitting "Setup".

      Thanks...

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks