#85 HAST UFS Automount?

9.1.0.1
closed
zoon01
None
1
2014-12-19
2013-02-23
No

I have a running HAST setup, but the hastswitch script does not automount my UFS hast device. I think this is because the script is pulling from the disk->mount point? these lines of code make me think that I should be able to setup UFS HAST.

# mount GPT/UFS
        /usr/local/bin/xml sel -t \
            -m "//mounts/*[type='hvol']" \

If the disk->mount points is the appropriate mounting option then that page is broken for hast devices.

http://sbtec.co/ref/13/02/ufsmount.png
http://sbtec.co/ref/13/02/mount.jpg

1 Attachments

Discussion

  • Erin O'Meara

    Erin O'Meara - 2013-02-25

    Was able to add the hast to mount points after changing one line of code. hast devices do not have partition numbers!

    line 234 - edit_mount_disk.php
    is
    $device = "{$_POST['hvol']}{$_POST['partition']}";
    should be
    $device = "{$_POST['hvol']}";

     
  • zoon01

    zoon01 - 2013-04-14

    Thanks for the report!

    fixed at rev. 668

     
  • zoon01

    zoon01 - 2013-04-14
    • status: open --> closed
    • assigned_to: zoon01
     
  • Daisuke Aoyama

    Daisuke Aoyama - 2013-04-14
    • status: closed --> open
     
  • Daisuke Aoyama

    Daisuke Aoyama - 2013-04-14

    Revert 668 fix. This is not a bug of mount.
    You must create a GPT header and a partition before using the HAST volume.
    But it seems no way to handle it from WebGUI.
    It should fix format WebGUI instead of mount.

    Note: the GPT header and extra space is very important for future label mounting.

     
    Last edit: Daisuke Aoyama 2013-04-14
  • Daisuke Aoyama

    Daisuke Aoyama - 2014-12-19

    9.3 should work with HAST volume.

     
  • Daisuke Aoyama

    Daisuke Aoyama - 2014-12-19
    • status: open --> closed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks