NAS on MS Vista (error: binding unix socket)

  • Mr.Montesa

    Mr.Montesa - 2007-08-06

    Hello Forum,
    has anybody tested NAS on Win Vista successfully?
    I got an error on starting up nas daemon.
    But perhaps it has nothing to do with Vista.
    I downloaded the 1.8 bins from the Wiki download link.
    here is the error message:

    Error binding unix socket: /tmp/.sockets/audio0
    : Bad file description

    Fatal server error

    Any ideas?
    Thanks in advance

    • Jon Trulson

      Jon Trulson - 2007-08-15

      It's possible this directory does not exist.  To my knowledge, no one has tried nasd on Vista.  You might try running nasd with the '-pn' option, which tries to run anyway if it could not bind to all of it's transports.

    • Mr.Montesa

      Mr.Montesa - 2007-08-22

      Hello Jon,
      of corse the directory on an windows box is not-existent.
      the option -pn isn't working working. Same error message as above.
      How do I run this on WinXP?
      Lets compare this and transfer to vista.
      thanks a bunch.

    • Jon Trulson

      Jon Trulson - 2007-08-22

      Well, I don't do much windows... The last time I tried a few months ago (for testing) was to simply run 'nasd -aa -b' in cygwin.  This worked fine.  I did not need to do -pn. 

    • Mr.Montesa

      Mr.Montesa - 2007-08-24

      Ok, using Cygwin as environment makes sense. There you have /tmp/.socket available.
      Is there no possibility to run NAS native on windows systems?

    • Jon Trulson

      Jon Trulson - 2007-08-25

      Sorry, not without a native windows audio (server) backend.  I'd do it if windows were my primary OS, but...


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks