#195 Upgrade Nant to Support Nunit 2.5.8

open-later
Ryan Boggs
Core (30)
5
2011-10-15
2010-12-08
No

The current version of the Nunit core supported by Nant is 2.2.8. Can this be upgraded to 2.5.8 (current)?

The Majority of the software companies training the new developers on Nunit 2.5.8. So, it would be convenient to use Nant <nunit2> tasks, if we keep the version up to date.

Discussion

    • summary: Upgrade Nant to Support 2.5.8 --> Upgrade Nant to Support Nunit 2.5.8
     
  • Boinst
    Boinst
    2011-07-05

    Use the "exec" task instead. Given that nunit is updated much more frequently than nant, it is silly to have the nunit2 task as part of nant at all. Switch to using "exec".

     
  • Ryan Boggs
    Ryan Boggs
    2011-10-15

    Should be tasked after 0.91 final due to the amount of api changes between 2.2.8 and 2.5+.

     
  • Ryan Boggs
    Ryan Boggs
    2011-10-15

    • assigned_to: nobody --> rmboggs
    • status: open --> open-later