Graphs not displaying - help needed

Help
Mark
2012-04-05
2015-04-07
  • Mark

    Mark - 2012-04-05

    Hi, I need a bit of help with my installation of nagios graph.

    I have Nagios version 3.3.1 set up and working. It's monitoring performance counters on some windows servers. I am trying to graph these  using nagiosgraph 1.4.4. I'm running these on Scientific Linux 5.7.

    I believe I am collecting data correctly in perfdata.log and in the rrd files.

    In perfdata.log there is information along the lines of.

    1333590538||server.domain.com||public ping||PING OK - Packet loss = 0%, RTA = 0.31 ms||rta=0.311000ms;100.000000;500.000000;0.000000 pl=0%;20;60;0
    1333590550||server2.domain.com||Counter Current Disk Queue Lenght||OK: \LogicalDisk(C:)\Current Disk Queue Length: 0||\LogicalDisk(C:)\Current Disk Queue Length=0;50$

    In /var/spool/nagiosgraph/rrd/ there are folders for each machine being monitored and there are multiple .rrd files in these folders. Inside these files there is a lot of gabled text.

    From the hosts status page I have the little graph image over the processes.

    When I click these a new page opens http://server/nagiosgraph/cgi-bin/show.cgi?host="my host and service info". This url displays a page not available error message. When I change it to http://server/nagios/cgi-bin/show.cgi?host="my host and service info" it will open a page that says JavaScript is disabled and nagiosgraph.js is not installed or wrong version, but it displays the graphs I am looking for.

    I pretty sure I messed up the config files somewhere but I'm not sure where. I can post snippets of whichever files are needed. Thanks in advance.

     
  • Mark

    Mark - 2012-04-05

    The title is incorrect I got the graphs working half way through writing. Forgot to change it. I still have the javascript error though.

     
  • Mark

    Mark - 2012-04-05

    I've sorted the issue regarding opening the graph in a new page using the wrong directory. The graphed-service definition was using the wrong url. It's working now but I have still got the following error:

    JavaScript is disabled.
    nagiosgraph.js is not installed or wrong version.

    This appears to limit functionality on the graph page.

     
  • Matthew Wall

    Matthew Wall - 2012-04-05

    check nagiosgraph.conf for the value of 'javascript'.  it is probably set incorrectly.  you should also check 'stylesheet'.

     
  • Jun Padilla

    Jun Padilla - 2014-06-06

    Hi there I suddenly have this
    JavaScript is disabled.
    nagiosgraph.js is not installed or wrong version.

    Prior to today it was working perfectly for almost a month, the only changes is that I'm adding host to be monitored by Nagios and installed MRTG

    When I checked the nagiosgraph.log I have this message

    Fri Jun 6 17:59:47 2014 insert.pl 22982 warn output/perfdata not recognized:

    Not if that is related

    Appreciate the assist

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks