Total Process Graph not working

Anonymous
2012-06-14
2014-01-10
  • Anonymous - 2012-06-14

    Hi all,

    I am new to nagios and nagiosgraph.

    I have just installed a fresh Ubuntu server LTS 12.04 and manually installed nagios 3.4.1 and nagiosgraph 1.4.4

    Everything seems to work. Localhost is configure for several services which all have data and all are green.
    When I enable the graphs I can see all graphs except for the Total Processes.

    For what I can tell there is no data exported into the perfdata.log file.

    The error I do get when opening the graphs for Total Processes: "No data available: host=localhost service=Total Processes db="

    I do not see any errors in the nagiosgraph.log nor in nagiosgraph-cgi.log (after enabling debugging of course)

    Any idea's where to look for this issue ?

    Regards,

    Ronald

     
  • santhosh

    santhosh - 2012-07-27

    Hi All,

    I am facing the same problem.

    Nagiosgraph is displayed for Current Load, Current Users, Root Partition..

    But of Total processes i see  "No data available: host=localhost service=Total Processes db="

    Rrd files are not created for Total_processes. Nagiograph.log does not have any entry corresponding the "Total processes"

    nagios.log has entries for "Total_processes" like
    CURRENT SERVICE STATE: USC;Total Processes;OK;HARD;1;PROCS OK: 32 processes with STATE = RSZDT

    Entry in map file by default was

    (/output:PROCS.*?(\d+) processes\n/ or
    /output:PROCS.*?(\d+) processes with STATE = RSZDT/)
    and push @s, [ 'procs',
                    ];

    Which on testing with testentry.pl failed to return the values, edited to below and got output from testentry.pl script

    (/output:.*PROCS.*?(\d+) processes\n/ or
    /output:.*PROCS.*?(\d+) processes with STATE = RSZDT/)
    and push @s, [ 'procs',
                    ];

    perl testentry.pl
    @s = (
           [
             'procs',
             [
               'data',
               'GAUGE',
               '32'
             ]
           ]
         );

    Please let me know if i am missing any thing, let me know if you need more details.

    Thanks in advance,
    Santhosh

     
  • sachin

    sachin - 2012-09-03

    I have same problem plz reply…

     
  • jsjks

    jsjks - 2012-09-04

    I just upgraded to Nagios Version 3.4.1 and nagiosgraph, which worked before the upgrade, also stopped logging Total proc data as well.  Plus a few other processes that I am monitoring.  I have been running Nagios and Nagiosgraph for years now and never has an upgrade had this affect.

    Does anyone know what happened? 

     
  • sachin

    sachin - 2012-09-05

    Hi all of you

    I have solve this problem after 3 days and now nagiosgraph is working for each service. just make a .sh file and enjoy..
    For total process you have to make a check_procs.sh script and put with check_procs then change command in command.cfg for total process. Bcz check_procs output format is not correct.

    How to check format of check_procs output :
    Go to nagios-plugins  directory where check_procs reside.
    at my system
    cd /usr/local/nagios/libexec
    then run below command
    ./check_procs -a firefox -w 1: -c 0:  

    then u get output like :
    PROCS OK: 2 processes with args 'firefox'

    after make check_procs.sh and put check_procs.sh in the same directory as check_procs.

    run command

    ./check_procs.sh -a firefox -w 1: -c 0:

    output:
    PROCS OK: 2 processes with args 'firefox'| procs=2

    My check_procs.sh script contents are :

    #!/bin/bash
    LINE=`/usr/local/nagios/libexec/check_procs $*`
    RC=$?
    COUNT=`echo $LINE | awk '{print $3}'`
    PROCS=`expr $COUNT - 1`
    LINE=`echo $LINE | sed "s/: $COUNT /: $PROCS /"`
    echo $LINE \| procs=$PROCS
    exit $RC

    and check_local_procs command definition in /usr/local/nagios/etc/objects/commands.cfg

    # 'check_local_procs' command definition
    define command{
            command_name    check_local_procs
            command_line    $USER1$/check_procs.sh -w $ARG1$ -c $ARG2$ -s $ARG3$
            }

    now restart nagios and after some seconds u will get graph for total process in nagios.

    For remote host, u have to create check_procs.sh at remote host and change total process command definition in nrpe.cfg
    change check_procs to check_procs.sh

    Enjoy!!!!

     
  • jsjks

    jsjks - 2012-09-05

    Thanks sachink299 for the suggestion, but that doesn't cover my situation.  I have a few metrics that stopped working after I upgraded, including total procs.  These were working for years before the Nagios upgrade.  I'm looking for a cause in the code to be honest, as nothing is showing up in the logs, even in debug mode, to help me figure this out.

     
  • jsjks

    jsjks - 2012-09-25

    I found my issue.   Apparently nagios no longer emits plugin output to the perfdata file if the plugin does not emit performance data.   I basically have added a pipe and "perfdata" to the output so nagios passes the output to nagiosgraph for processing.  See this thread for details: 

    http://www.mail-archive.com/nagios-users@lists.sourceforge.net/msg36835.html

     
  • Ken

    Ken - 2014-01-10

    I've added a | "perfdata"
    and I've tried Sachin's script to no avail.

    Has anyone else found a fix?

    It seems this issue still exists in Nagios 3.4.1 and Nagiosgraph 1.4.4. I guess an alternative would be to install an older version of Nagios, but I'd rather not.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks