Gap in the graphs

dan
2012-02-10
2013-05-20
  • dan

    dan - 2012-02-10

    Running 1.4.4 nagiosgraph + nagios 3.2.3

    Can't seem to find why there are gaps in the graphs even though the data seems to be matched properly according to the debug log:

    Fri Feb 10 10:14:46 2012 insert.pl info processing output/perfdata:
    hostname: somename
    servicedesc:cpu_snmp
    output:SNMP OK - CPU_% 27 5 68
    perfdata:
    Fri Feb 10 10:14:46 2012 insert.pl debug createrrd(1328897652,somename,cpu_snmp,cpu_per)
    Fri Feb 10 10:14:46 2012 insert.pl debug createrrd rrdfile is /nagios/nagiosgraph/rrd/somename/cpu_snmp___cpu_per.rrd
    Fri Feb 10 10:14:46 2012 insert.pl debug createrrd step=300 heartbeat=600 xff=0.5 resolutions=4 steps=1 6 24 288
    Fri Feb 10 10:14:46 2012 insert.pl debug labels-> = [
      'usr_percent',
      'GAUGE',
      '27'
    ];
    Fri Feb 10 10:14:46 2012 insert.pl debug labels-> = [
      'sys_percent',
      'GAUGE',
      '5'
    ];
    Fri Feb 10 10:14:46 2012 insert.pl debug labels-> = [
      'idle_percent',
      'GAUGE',
      '68'
    ];
    Fri Feb 10 10:14:46 2012 insert.pl debug createrrd filenames = [
      'cpu_snmp___cpu_per.rrd'
    ];
    Fri Feb 10 10:14:46 2012 insert.pl debug createrrd datasets = [
      [
        0,
        1,
        2
      ]
    ];
    Fri Feb 10 10:14:46 2012 insert.pl info runupdate dataset = [
      '/nagios/nagiosgraph/rrd/somename/cpu_snmp___cpu_per.rrd',
      '1328897653:27:5:68'
    ];

    my map for this looks like this
    # CPU in %
    /output:.*SNMP\s\w+\s- CPU_% (\d+)\s(\d+)\s(\d+).*/
    and push @s, [ 'cpu_per',
                    ,
                    ,
                    ,
                ];

     
  • dan

    dan - 2012-02-10

    another strange thing is that - i can see the output properly on the nagios but the output doesnt seem to be added to the rrd files. Once i turned on the debugging and force checking again from nagios, the data seems to be added to rrd again.

     
  • Matthew Wall

    Matthew Wall - 2012-02-11

    what do you mean by 'force checking again from nagios'?

    typically gaps are caused when data are not available, either because nagios fails to collect data (e.g. network failure between nagios and the nagios target) or the nagios sampling interval does not align with the nagiosgraph heartbeat/stepsize.  see 'My graphs are fragmented/spotty. Why?' in the nagiosgraph FAQ.

     
  • dan

    dan - 2012-02-24

    When i say force checking, i mean to manually recheck the service under nagios from web or by command.  nagiosgraph.log doesnt show the checking of the service that are suppose to be scheduled to ran unless i force reschedule it.

    this is quite odd …. I have upgraded to 3.3.1 nagios and this still happens.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks