Ok, I remove the nrpe side and configured instead my service for the host.

I changed it to this:
define service{
        use                            local-service
        host_name                serveip1.csaa.com
        service_description  SMTP
        check_command      check_smtp!/check_smtp -p 25 -w 5 -c 8 -t 100
       }

Am I missing something?

Thanks.


From: Mathew Walker <lmw94002@hotmail.com>
To: deibertine@yahoo.com; nagios-users@lists.sourceforge.net
Sent: Wednesday, July 1, 2009 9:58:22 AM
Subject: RE: [Nagios-users] check_smtp issue

What is your service configuration?  If you're checking SMTP remotely, there is no need for NRPE here.  I would guess your service configuration is not passing the correct variables.

--
Mat W. - http://www.techadre.com/


 

Date: Tue, 30 Jun 2009 20:04:49 -0700
From: deibertine@yahoo.com
To: nagios-users@lists.sourceforge.net
Subject: [Nagios-users] check_smtp issue

I have setup check_smtp in my Nagios to possibly check smtp flow.

I have manually tested initiated this command and seems to be ok:
nagios@servedhcp1~/libexec# ./check_smtp -H serveip1.csaa.com -w 3 -c 5 -t 100
SMTP OK - 0.003 sec. response time|time=0.002578s;3.000000;5.000000;0.000000

Configured my cfgs in command.cfg:
define command{
command_name check_smtp
command_line $USER1$/check_smtp -H $HOSTADDRESS$ -p 25 -w $ARG1$ -c $ARG2$ -t $ARG3$
}

Configured on host nrpe:
command[check_smtp]=/usr/local/nagios/libexec/check_smtp -p 25 -w 5 -c 8 -t 100

However when I check nagios page, I'm getting this error:
check_smtp: Warning time must be a positive integer

Any ideas on why this is happening?

Please advise.

Thanks!
DB



Lauren found her dream laptop. Find the PC that’s right for you.