Map tiles black (12.6)

  • Veijo Länsikunnas

    With 12.6 the map tile where tour is located are drawn with black background, which makes this version quite useless. I am running the 64-bit linux version on Ubuntu 12.04 LTS.

  • Wolfgang

    Wolfgang - 2012-06-23

    I tested it with Ubuntu 10.10 and it worked, but now I will do tests with Ubuntu 12.04

  • Dering

    Dering - 2012-07-01

    I can confirm the problem with Linux Mint 13 64-Bit.  The enhanced method for tile painting does work flawless.

    Thank you Wolfgang for the software!

    Take care that you have installed the 32-Bit Java-VM (otherwise MyTourbook will not start-up).

  • Veijo Länsikunnas

    The enhanced method works perfectly. The vmargs needed to be set to avoid crash at higher zoom levels.

  • Dering

    Dering - 2012-07-02

    I have tried to add the vmargs options like:

    ./mytourbook -vmargs -Xms128m -Xmx768m

    but I still get a lot of crashes while zoom in/out with the following error message:

    mytourbook: /build/buildd/cairo-1.10.2/src/cairo-surface.c:614: cairo_surface_reference: Assertion `((*&(&surface->ref_count)->ref_count) > 0)' failed.

    This seems to be another issued (multi-threading problem) - and occurs when
    calling set_source_surface on an invalid surface. (

    Wolfgang - could you please check this? Let me know if you need further traces etc.

  • Wolfgang

    Wolfgang - 2012-07-02

    I fixed the problem for the basic painting method, available in the next version (will be released in a few weeks)

    I will not fix issues which are deep in the cairo library, I have no skills to solve it at this location

  • Dering

    Dering - 2012-07-17

    Hi Wolfgang,

    thank you for the bug fix. Version 12.6.1. is working perfect!




Log in to post a comment.