Using FUSE option problem

Help
2007-08-30
2013-04-25
  • Nobody/Anonymous

    Hi all,

    Thanks for your work. It's a good idea.
    I've find a problem on using FUSE option such as "-oallow_other" etc. It seems that in function mysqlfs_opt_proc, the arg passed in when handling "-oallow_other" is just the string "allow_other". So when adding the option back to arg list, an "-o" prefix must be added. Otherwise fuse main will only get the argv[x]="allow_other" not "-oallow_other". And it the option will not be handled correctly by FUSE.

    Best regards,
    Richard

     
  • Nobody/Anonymous

    As a work around you can specify the options to pass to FUSE like:

    mysqlfs -o\-oallow_other -ohost=localhost -ouser=user -opassword=password -odatabase=mysqlfs  ./fs

    note the \-0 escape. this passes -oallow_other to the fuse main

     

Log in to post a comment.