#5 Umlaute als "?" importiert MySQL 5.0.67

V1.24
closed
Web-GUI (6)
5
2012-09-11
2009-11-17
No

Bei einem Dump und wiederherstellen über MSD 1.24 werden Umlaute als "?" kodiert.
Beide MySQL haben laut MSD gleiche Einstellungen, beide dieselbe Version: 5.0.67-community-log

character_set_client utf8
character_set_connection utf8
character_set_database latin1
character_set_filesystem binary
character_set_results utf8
character_set_server latin1
character_set_system utf8
character_sets_dir /usr/share/mysql/charsets/
collation_connection utf8_general_ci
collation_database latin1_swedish_ci
collation_server latin1_swedish_ci

Der Fehler tritt auch auf demselben Server auf, nach Backup und wiederherstellen.

Discussion

  • Daniel Schlichtholz

    Das kann eigentlich nur passieren, wenn man die Backup-Datei mit einem Text-Editor manuell verändert und unbewusst in einem falschen Zeichensatz abspeichert. Ist das hier der Fall?
    Ansonsten benötigt man zur genauen Analyse des Falls die Backup-Datei.

     
  • Michael Kreutzer

    Nein, das wurde nicht bearbeitet. Wo soll ich die Backupdatei hinschicken?

     
  • Daniel Schlichtholz

    Bitte an admin@mysqldumper.de .
    Ich schaue mir das dann gerne an und melde mich mit den daraus gewonnenen Erkenntnissen.

     
  • Daniel Schlichtholz

    Nicht reproduzierbar.
    Das entstandene Backup ist inklusive der Umlaute einwandfrei.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks