mysar-importer.php problem

vchawla
2007-12-27
2013-04-24
  • vchawla

    vchawla - 2007-12-27

    I have recently installed mysar on Fedora 7. But when I run this importer. I get the following error:
    #!/usr/bin/php ERROR: squid log file(/var/log/squid/access.log) does not exist! Exiting...

    Although my access.log is exactly in /var/log/squid/ location.

    Is there anything else which needs to be done before running this importer.

     
    • abottegal

      abottegal - 2008-01-03

      Hello,

      I have the same problem on OpenSUSE 10.2, if I run manually the mysql-importer.php with debug level at 50 it report:

      #!/usr/bin/php /srv/www/htdocs/mysar/inc/common.inc.php(38) -> Disabling
      PHP's execution time limit...Yes Initializing database connection...
      dbHost=localhost,dbUser=xxxx,dbPass=yyyy Done. Selecting database...
      dbName=mysar Done. Start timestamp is 1199368603 Configuration:Array (
      [dbUser] => xxxx [dbPass] => yyyy [dbHost] => localhost [dbName] => mysar
      ) (SELECT value FROM config WHERE name='mysarImporter') Getting last
      proccessed record timestamp... (SELECT value FROM config WHERE
      name='lastTimestamp')0 (SELECT value FROM config WHERE
      name='squidLogPath') Opening log file/var/log/squid/access.log... ERROR:
      squid log file(/var/log/squid/access.log) does not exist! Exiting...

      anyone can help me? Thank you in advance

       
      • Philipp Glaser

        Philipp Glaser - 2008-04-22

        i have exactly the same problem. the file exists on the very location and i tried to change ownership, user acces rights;

        no success

        any clue, whats going on?

        philipp

         
        • Vladimir Mendelevich

          Check if You don't have problems with SELinux

          You can test it like this:

          $ /usr/sbin/getenforce
          Disabled
          $

          If You get "Enforced" You have SELinux activated. If You have "Permissive" it is activated but does nothing.
          Also You can look at /var/log/audit/audit.log

           
    • melih

      melih - 2008-01-22

      Hi,

      I hve the same problem on mysar.On my Cetos-5.

      Doesn't anybody know the problem solution?

       
    • si13ncer

      si13ncer - 2008-11-18

      chmod -R 777 access.log
      it must be set to execute
      also id put this in your cron.d so when the logs rotate it will auto set permissions on the new one

       
    • zerocold shuan

      zerocold shuan - 2008-11-20

      by changing permission to access.log only still prompt "does not exist" error.
      by adding execute permission to /var/log/squid...settle.

       
    • si13ncer

      si13ncer - 2008-11-20

      oops i forgot to add that youll have to chown -R squid:root access.log as well, then chmod -R 777 access.log

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks