No Driver / Providers available after Install

  • Sparks

    Sparks - 2011-05-31

    I installed the software on 2 seperate machines - both with MySQL and SQL Server 2008 R2 installed on them.  No drivers appear, at all, in the connection screen when the application starts.  I even went and downloaded the MySQL2 driver and relaunched he application with no luck.  Any suggestions on how to resolve this?

  • rgardner

    rgardner - 2011-06-08

    Having exactly the same issue.  Setting up a new development machine so I have a fresh install of Vista and a get no options at all in the drivers drop down box.

    Any help appreciated

  • Mark Oudesluys

    Mark Oudesluys - 2011-07-05


    I'm also having the same issue, where I have no driver options in MyGeneration on a Win7-32 machine.

    Any ideas?  Is there any body out there?

  • karepa

    karepa - 2011-08-09

    HI All.

    I am having this issue on a Windows 7 64 bits machine.

    With de version 1.3.1 it shoes the drivers but does not generate any class or stored procedure.
    The template I am using works perfect on a XP development machine.

    I have tried lozenlin suggestion but does not show the drivers.

    Any suggestion is appreciated.

  • Anonymous - 2011-08-09

    same here with Win7 32bit.
    But then I suspect that is cause by Win7 UAC.
    So then I run the application with "Run as Administrator", then it works.
    Hope that sort it out for you all.

  • karepa

    karepa - 2011-08-10

    Hi Maxi.

    Does not work on windows 7 64 bits

    Version 1.3.10 install without a problem, has all drivers but does not generate concrete classes or stored procedures files.

    Version 1.3.09 (Untick) the MDAC 2.7+ Install withou problems but does not show any driver.

    Running as administrator in any case I got the same result.

    Any Idea ?

  • karepa

    karepa - 2011-08-10

    Hi Guys.
    Latest update on the issue.

    Version 1.3.10 (W7 x64) is not generating files if the template is vbscript.
    jscript is working perfectly


    What the difference on vbscript between xp and w7 ?

  • karepa

    karepa - 2011-08-10

    Final Chapter.

    the following command is not working on Windows 7 64

    For Each objColumn In objTable.PrimaryKeys

    Any Ideas ?

  • karepa

    karepa - 2011-08-10

    Hi All
    Finaly I got it working

    All For Each statements have to be replaced by

    For intX = 0 to objTable.Columns.Count -1
    objColumn = objTable.Columns(intX)

    and so One.

    Hope it helps

  • This Site Sucks

    This Site Sucks - 2011-08-22

    This is the error I get under Windows 7, 64 bit edition

    Access to the registry key 'HKEY_CLASSES_ROOT\MyMeta.SQLite.SQLiteDatabase' is denied.

       at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
       at Microsoft.Win32.RegistryKey.CreateSubKeyInternal(String subkey, RegistryKeyPermissionCheck permissionCheck, Object registrySecurityObj, RegistryOptions registryOptions)
       at Microsoft.Win32.RegistryKey.CreateSubKey(String subkey)
       at System.Runtime.InteropServices.RegistrationServices.RegisterManagedType(Type type, String strAsmName, String strAsmVersion, String strAsmCodeBase, String strRuntimeVersion)
       at System.Runtime.InteropServices.RegistrationServices.RegisterAssembly(Assembly assembly, AssemblyRegistrationFlags flags)
       at System.EnterpriseServices.RegistrationDriver.ClassicRegistration(Assembly asm)

  • Khurram Saddique

    I have also the same problem with
    windows xp sp3
    sql server 2008 developer edition
    visual studio 2010
    when i installed mygeneration drivers were shown but when i restarted the system they were never shown
    i tried to clear mygeneration entries in regedit but no success
    i tried to reinstall several times but nothing change
    and worse i didnt find any solution anywhere
    kindly anyone help please ?????

  • Brian LaLonde

    Brian LaLonde - 2012-06-08

    I was also having the problem with "For Each objColumn In objTable.PrimaryKeys" in version 1.3.1

    But I was also unsuccessful in uninstalling 1.3.1 and going back to 1.3.0.

    For the record, I tried these steps:
    -uninstall 1.3.1
    -delete the whole old folder that still remains: programfiles/mygeneration
    -delete c:\Users\\AppData\Roaming\MyGeneration Development Community\
    -Remove registry items that still remain:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\LowRegistry\Audio\PolicyConfig\PropertyStore\1be01119_0

    And then I ran the 1.3.0 installer as admin, and ignore mdac…

    But no good – still no items in the database Drivers dropdown.

    What could it be that keeps the bad setting when you revert back to 1.3.0?


  • Anonymous - 2012-06-08

    HI All.

    Work around for Error on For each objColumn

    Replace the statements For each by For intX = 0 to …

                For intX = 0 to objTable.Columns.Count -1
                        objColumn = objTable.Columns(intX)

                For intX = 0 to objTable.PrimaryKeys.Count -1
                        objColumn = objTable.PrimaryKeys(intX)

    Those changes worked out for me.

    Stay tuned.

  • Anonymous - 2012-06-15

    Thanks for the help everyone in getting to this point. I am still running into an error after making the change form For Each to For intX.

    I am getting an "Object required: 'objColumn'" error on the GetAlias support function.
    Error line: name = TrimSpaces(objColumn.Alias)

    I cannot figure out why, this function should take a simple column object trim and return but it would seem that GetAlias is not getting a column at all, or maybe it's that the column doesn't have an Alias property? Any ideas?

  • Anonymous - 2012-06-18

    Try this approach.

  • Anonymous - 2012-06-18

    I tried your approach but found it not all encompassing. I had to update every instance of objColumn to get the script to compile, run and produce output. (Not just the function calls) From there I was able to debug and work backward to find out that the problem is with passing the parameter as an object. When passing the parameter as a reference it works just fine. I updated my loop code as  such:

    For intX = 0 to objTable.Columns.Count-1
        set objColumn = objTable.Columns(intX)

    I made the same change to the Primary Key column loops as well.

  • Anonymous - 2012-06-18

    I did not understand what you mean by "When passing the parameter as a reference it works just fine". Could you please post an example?

    Thanks in advance

  • peeterminy

    peeterminy - 2012-07-11

    I  had gone through your  post. I thought that the code generation has failed in your software.  I too working on the conversions of php and sql codes in my projects. The soft ware should be very effective and have to work efficiently for the proper functioning of the task.

    generate QR codes/generating QR codes
    Trackable QR codes

  • fpdavis

    fpdavis - 2012-10-01

    Here is the fix for the Drivers dropdown list not being populated. You may be able to skip the first two steps and do this after installation, but if that doesn't work, uninstall and install using the following…

    1. Uncheck the option for MDAC 2.7+ during setup
    2. After installation click “No” when asked to “Launch MyGeneration?”
    3. Launch the Visual Studio 2010 Command Prompt (Run as Administrator)
    4. Change directory to your MyGeneration13 install directory (i.e. "c:\Program Files (x86)\MyGeneration13\")
    5. Run the following command… regasm.exe MyMeta.dll /tlb: MyMeta.tlb
    6. Exit Command Prompt when successfully registered
    7. Run MyGeneration!


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks