build under linux with error

  • Dietmar Hermanns

    I use Kubuntu and tried to compile mxflib-0.6.0 and after configure and make the following error meassage came up.
    I did the same with mxflib-beta-1.0.0-rc5, same error. I don't know how to checkout what's wrong!

    g++ -DHAVE_CONFIG_H  -I..   -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -DDEFAULT_DICT_PATH=\"/usr/local/share/mxflib\" -Wall -g -O2 -MT crypto.o -MD -MP -MF .deps/crypto.Tpo -c -o crypto.o crypto.cpp
    ../mxflib/mxffile.h:207: error: extra qualification ‘mxflib::MXFFile::’ on member ‘ReWritePartition’
    ../mxflib/mxffile.h:216: error: extra qualification ‘mxflib::MXFFile::’ on member ‘ReWritePartitionWithIndex’
    make[2]: *** [crypto.o] Fehler 1
    make[2]: Verlasse Verzeichnis '/usr/local/src/mxflib-beta-1.0.0-rc5/mxflib'
    make[1]: *** [all-recursive] Fehler 1
    make[1]: Verlasse Verzeichnis '/usr/local/src/mxflib-beta-1.0.0-rc5'
    make: *** [all] Fehler 2

    • Dietmar Hermanns

      I solved the problem. I removed at mxflib/mxffile.h in line 207 and 216 the string "MXFFile::", and it works! I don't know why, because I am not a programmer. But look at the item "compilation problem " at the forum.

      • Matt Beard

        Matt Beard - 2007-01-31


        4.0.0 does not show this, but the error has now been cleared and checked-in

    • Matt Beard

      Matt Beard - 2007-01-31

      This can be simply fixed by removing the extra qualifications that the compiler say are a problem.

      A copy and paste error left MXFFile:: prefixes on declarations within the MXFFile class header.

      The interesting thing is that this has been in the code for over 3 years and none of the test compilers have spotted it. What compiler version are you using?

    • Dietmar Hermanns

      I use /gcc --version
      gcc (GCC) 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)
      Copyright (C) 2006 Free Software Foundation, Inc.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks