Trouble with latest CVS build (--startup)

  • Bryan P. Pourciau

    I just performed a build from CVS and added the option '--startup mclient' to the mvpmc line of my .config file.

    After the MediaMVP loads the new dongle file, the display does not come up.  There is a constant rolling flicker on my TV screen as if there is not video signal being output.  Also, attempts to connect to the unit via telnet while it is in this state fail.

    I have reverted back to my last stable build for now.  Am I missing something?  Any ideas?

    • Jon Gettler

      Jon Gettler - 2006-02-11

      It works fine for me.  My guess would be that the code you checked out did not contain Rick's changes.  The anonymous CVS server tends to lag a few hours behind the developer one, so see if a "cvs update" fixes it.

    • Bryan P. Pourciau

      I tried the "cvs update" and still no dice.  Here is the script I have been using to grab the latest code from CVS and to build it (note, the cvs update lines are new):

      cd mvpmc
      cvs login
      cvs  update
      cvs -z3 co build
      cd build
      cd release
      cvs login
      cvs update
      cvs -z3 co mvplib
      cvs -z3 co mvpmc
      cd ..
      CC=/opt/crosstool/powerpc-405-linux-uclibc/gcc-3.3.3-uClibc-0.9.23/bin/powerpc-405-linux-uclibc-gcc ./configure --with-mvpmc-mediamvp --with-mvpmc-host 
      make populate
      make configure

      After running this, it says the build is successful.  Any more ideas?


      OS: SuSE 9.1 (updated regularly using apt4suse)

    • Rick Stuart

      Rick Stuart - 2006-02-11

      Well, I know I initially had problems because the display process had not started yet and the attempts the main MVPMC process made to contact to it resulted in MVPMC resetting (kind-of like you describe).  But you probably didn't enable that feature (i.e. "-d IEE16x1" for instance). In addition, I changed the code to printout a "problem message" rather then reset the MVPMC box.

      I can't think of another problem off the top of my head. Can you give us an example of your /bin/mvpmc <options> line? 

      I just tried this one and it works fine:
      /bin/mvpmc -R discover -o passthru  -d IEE16x1 -c --startup mclient
      And in case you don't have a replayTV or the serial port installed, this one worked for me as well:
      bin/mvpmc  -c --startup mclient

      And for the next step (I am ahead of myself) you might try to omit the command from the config file and start it up manually while telnet'ed into the MVPMC box.  That way you will see printouts of this or that as the program executes.  Some of which might give you insight as to what is going wrong.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks