SourceForge has been redesigned. Learn more.

no playback until reboot

  • allams

    allams - 2006-06-21


    I've started trying to use mclient with slimserver, and have hit a strange problem.

    When I start playing anything, the screen says that a track is being played, but there is no sound. Its not a volume thing.  If I reboot the mvpmc, by pressing the green button on the remote twice, then go to the mclient, the music starts playing!!!

    Now, if I press stop, then play, again nothing, unless I reboot the machine again!

    So either I'm being very silly, or there is a problem.

    I run mvmpc v0.3.0 and start from a config file with the following line:

    mvpmc -f /etc/helvR10.fnt -s -D -c --startup mclient &

    The problem also occurs without the --startup mclient line...

    Any suggestions would be welcome



    • Rick Stuart

      Rick Stuart - 2006-06-21

      Interesting, let me have a try at it...

      Nothing like that here. However, I am running a up-to-date as of 6-21-2006 GIT.

      Let me try the 0.3.0 dongle...

      Still works.  However, I don't have your configuration - I am using the following startup command:
      mvpmc -f /etc/helvR10.fnt -c <my_server_addr> -startup mvlient
      (...mythtv box isn't working yet)

      What version of slimserver are you using?  I see:
      SlimServer Version: 6.2.1
      ...on my slimserver's web page (<my_server_addr>:9000).

      Several things:
      1) There does appear to be a initialization problem with what MClient and Slimserver are thinking.  But I haven't see that inhibit the playing of tracks.  Only appears to effect the play/stop/pause display at the top of the full screen MClient OSD.

      2) The state MClient is really controlled by Slimserver.  That is, all button pushes go through Slimserver first.  And Slimserver decides on what to do next.

      3) MClient is now using the CLI port of Slimserver to support its full screen OSD.  The CLI is still new and is different for different versions of Slimserver.  I held back on requiring the Beta version of Slimserver - but had to sacrifice the stability of the full screen OSD when playing back internet radio stations.

      What to do next:
      Verify your Slimserver is up to date with the latest stable release. If that doesn't work, try a simpler command line like the one I used above. And if that doesn't work, try to control MClinent from you Slimserver's web page.

    • allams

      allams - 2006-06-21


      Thanks for the quick reply.

      I have tried with a shorter command string (same one as yours) and still have the problem.

      My slimserver version is 6.2.2 so slightly higher than yours,- might this cause the issue.  I am quite happy to try either a later or earlier version to see.

      Also, I have tried both using the remote and the slimserver web page to control the music,- both give the same result.

      Also, I have tried without the --startup line, just in case.

      All give the same results.


    • allams

      allams - 2006-06-21


      After saying its not a volume thing, it appears to be a volume thing...

      The volume goes from very quiet to normal on a reboot of the mvp.  Here are the scenarios:

      Turn on the mvp, go to the slimserver web page,you can see the client there, set-up a playlist etc.  The volume set here appears to be the default of 5.  Press play,- nothing can be heard unless you put the volume on the stero right up (v high).  Reboot the mvp, (using remote) and the volume goes to normal. 

      Whilst in the low volume state, rather than rebooting the mvp, you can wack up the volume on the slimserver web, and that works too!  Strangely here, if you do that, then reboot the mvp then the volume doesn't get *louder*...

      So I have a workaround, and I need to find out how to set the default volume on the slimserver.

      I would say therefore that there is some sort of initialisation issue between the mclient and slimserver to do with setting initial volume levels.  Also, if you leave the slim server volume as the default, this problem occurs every time you stop and start a track on the mvp...


      • Rick Stuart

        Rick Stuart - 2006-06-22

        Ok, I have 6.2.1 and 6.2.2 running on different servers and I do see the problem.  I suspect the CLI format has changed - but a quick A / B comparison and look at the 6.2.2 release notes does not point at anything.  I'll look at it again later today...

    • tkgafs

      tkgafs - 2006-10-07

      I have just tried mvpmc for the first time and downloaded the latest version available dongle.bin.mvpmc-2.4.31-latest and slimserver 6.5.0 and can confirm this is still happening.

      I am using gbpvr to load the dongle would this make any difference ?



Log in to post a comment.