enabling vlc and mclient in config file

Windows
Pexcer
2006-12-07
2013-06-03
  • Pexcer

    Pexcer - 2006-12-07

    I can't seem to enable vlc or mclient with the config file.

    Here is my config file

    TZ=CST+6CDT,M4.1.0/2,M10.5.0/2; export TZ;
    echo "TZ=CST+6CDT,M4.1.0/2,M10.5.0/2; export TZ" > /etc/shell.config;
    rdate -s 192.43.244.18;
    mkdir /Videos;
    mkdir /Pictures;
    mkdir /Music;
    mount.cifs //192.168.15.2/my\ music /Music/ -o username=guest,password=guest;
    mount.cifs //192.168.15.2/my\ pictures /Pictures/ -o username=guest,password=guest;
    mount.cifs //192.168.15.2/videos /Videos/ -o username=guest,password=guest,rsize=34000;
    mvpmc "ip=discover" -t /usr/share/mvpmc/replaytv.xml &
    --vlc 192.168.15.2;
    -c 192.168.15.2;
    --web-port 80

    I see the config file upload in tftp and the shares are all mounted correctly but I always end up having to enter the IP addresses for vlc and mclient with the GUI, also I don't think the time command line is working because when I log into the web config it doesn't show the time right, in fact what the webconfig shows doesn't match up with the running settings in a lot of ways. 

    I tried entering the vlc command as above with telnet and it goes into an endless loop of text which says something about failing to initialize the hardware.

     
    • MVallevand

      MVallevand - 2006-12-08

      The ampersand is like an end of line so all the command line options after it will be treated like command.  This should do what you want the web-port is the default anyway

      mvpmc "ip=discover" -t /usr/share/mvpmc/replaytv.xml --vlc 192.168.15.2 -c 192.168.15.2 &

      As for the rdate maybe select another public time server.   The command looks ok although you use more semicolons in your script than is my preference.  Later on, if you find you find that time drifts, since replaytv can be picky about time you might consider ntpclient to keep the time accurate.

      /bin/ntpclient -s -h 192.43.244.18
      /bin/ntpclient -d -l -h 192.43.244.18

      Martin

       

Log in to post a comment.