with version 1.0.0 clients with version numbers lower than 1.0.0 can't connect, but these clients aren't denied by the server. The connection from these clients isn't dropped, they just get a timeout after a while. So it isn't clear to the user that he has to update his client.