SUPW Problems

Help
2007-07-15
2012-10-30
  • SteveM AKA pENdr4gON

    I'm trying out Mumble/Murmur as a possible replacement for TS2 for the clan I'm in.

    I have the server running and I have tested it and OK it works. I have a few issues.

    1. Punkbuster doesn't like the overlay and will kick you in Battlefield:2 shame because it's a cool feature.
    2. I set the Super User Password but I'm having all sorts of problems logging in. Is there a way of clearing it or editing it directly or something to give me some control?
    3. How do I end/kill mumble on the server?
    4. I need it to auto start when our Dedi-Box restarts, any suggestions?

    The Dedi-Box is running Windows XP Pro and remotely hosted.

    Thanks SteveM
    Server Admin TSS Clan

     
    • SteveM AKA pENdr4gON

      another quick question... Plugins?

      Where do I get the BF:2 plugin? and how/where do I put it?!? Server side? client? I'm running more than one BF:2 server just to add to the complexity.

      Sorry for all of the questions...

      SteveM

       
    • SteveM AKA pENdr4gON

      I have gotten around it by deleting the murmur.sqlite file, it made a new one once I restarted murmur. I have a superuser password and log in working just fine now.

      I'm having a poke around to see what's what... I'm sure that there will be questions, sorry but thanks for all of your help.

      PS IP is 195.20.109.95 PW tss if you want to come on and have a chat...

       
    • Thorvald Natvig

      Thorvald Natvig - 2007-07-15

      It's been a while since I played BF2, so I can't comment on this. It didn't do any kicking at the time, but things might have changed.

      You can reset the supw as many times as you like with "murmur -supw thesecret"

      At the moment, the only way to kill mumble on Windows is to kill the process. This is fixed in 1.0.0

      QService, the Qt module which provides windows service support, is only available for the commercial Qt customers. So at the moment, you need to be logged in to start and run murmur. .. Actually, you can just put it in the startup group, but you'll still need to login to have it "autostart".

       
    • SteveM AKA pENdr4gON

      Thanks for your reply, I have tried the "murmur -supw" from the 'Command Prompt' and then tried to log in without any luck. The message pops up telling me that the Super User Password is set. I then try to logon using the password but still the "rejected: Invalid Password" message

       
    • SteveM AKA pENdr4gON

      I really should not answer my own posts, but...

      I'm now using version 1.0.0 on the server side as well as Client

       
      • Thorvald Natvig

        Thorvald Natvig - 2007-07-15

        In that case...

        First, make sure murmur isn't running.

        open a command prompt

        Start murmur with 'murmur -v'. Open the log (right-click the icon)

        Set the password with 'murmur -v -supw supersecret'

        Make sure they both report using the same database, and that the specified database file actually exists.

        Then try loggin in to your server with the username "SuperUser" and the password "supersecret".

        And no, don't substitute supersecret with something else. Or SuperUser. Try with that exact combination :)

         
    • SteveM AKA pENdr4gON

      Here is the contents of the log file.

      <D>2007-07-15 17:09:27.984 Initializing settings from C:/Program Files/Mumble/murmur.ini
      <D>2007-07-15 17:09:30.640 Openend SQLite database C:/Program Files/Mumble/murmur.sqlite
      <W>2007-07-15 17:09:34.078 Server listening on port 64738
      <W>2007-07-15 17:09:34.078 Not registering server as public
      <D>2007-07-15 17:09:34.078 Starting UDP Thread
      <D>2007-07-15 17:09:34.078 Entering UDP event loop
      <W>2007-07-15 17:11:06.765 <1:(-1)> New connection: 86.15.50.113:2146
      <W>2007-07-15 17:11:06.765 <1:SuperUser(-1)> Rejected connection: Invalid server password
      <W>2007-07-15 17:11:06.781 <1:SuperUser(-1)> Connection closed:

      The 'Wrong server password for unregistered user account, please try again.' message box apears giving me the option to change the password.

      Also the database file is there.

       
    • Thorvald Natvig

      Thorvald Natvig - 2007-07-15

      For some reason, and I really am not sure why, your installation has failed to create the SuperUser account. This is kinda odd as it is rechecked every single time the server is started.

      Does the user you are running murmur as have write permissions in the installation directory?

      And if so, could you send me the murmur.sqlite file? I'll see if I can figure out what's wrong with it.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks