Invalid Channel Name after adding expressions to ini file

Help
Urumii
2013-10-23
2013-10-25
  • Urumii

    Urumii - 2013-10-23

    I've been trying for over an hour to add expressions to the usernames and channelnames of my server. I seem to have done the complete opposite. Now I can't use ANY character, not even basic abc characters in a channel name. No matter what I change it to, I get the "Denied: Invalid channel name." error.

    The first thing I did was add the two lines documented in two places on the mumble wiki. That didn't work, so I removed them. That still didn't work. I added them back, changed them a little, nothing. I tried putting them in different spots in the file. Nope. Tried reverting back to an old file, still nothing.

    I've tried dozens of things to fix this, but now I can't add or edit any channels no matter what text i enter. Can anyone help me out?

    Here is my full ini file with the default values for username and channelname.

    How many login attempts do we tolerate from one IP

    inside a given timeframe before we ban the connection?

    Note that this is global (shared between all virtual servers), and that

    it counts both successfull and unsuccessfull connection attempts.

    Set either Attempts or Timeframe to 0 to disable.

    autobanAttempts=10
    autobanTimeframe=120
    autobanTime=300

    To enable public server registration, the serverpassword must be blank, and

    this must all be filled out.

    The password here is used to create a registry for the server name; subsequent

    updates will need the same password. Don't lose your password.

    The URL is your own website, and only set the registerHostname for static IP

    addresses.

    registerName="$$name$$"

    registerPassword="secret"

    registerUrl="http://www.multiplaygameservers.com/"

    registerHostname=$$ip$$

    password=REMOVED

    Welcome message sent to clients when they connect

    welcometext="REMOVED"

    channelname=[ \-=\w\#\[\]\{\}\(\)\@\|]+
    username=[-=\w\[\]\{\}\(\)\@\|\.]+

    Core settings - DON'T CHANGE

    port=$$port$$
    users=$$max_players$$
    serverpassword=$$game_passwd$$
    host=$$ip$$
    bandwidth=560000

    [Ice]
    Ice.Warn.UnknownProperties=1
    Ice.MessageSizeMax=65536

     
    Last edit: Urumii 2013-10-23
  • Natenom

    Natenom - 2013-10-25

    Try to escape the backslashes like in https://github.com/mumble-voip/mumble/blob/master/scripts/murmur.ini#L117 or comment out both settings.

    Did you use an admin interface to change these settings? If so, they are stored in the database for every virtual mumble server and changing the .ini won't help. You must then change them in the database.

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks