raf - 2014-02-25

I'm able to compile mumble just fine, but when I remove +CONFIG=no-server (to compile murmur) I fail to link at what I assume is one of the last steps:

    link /LIBPATH:"\dev\OpenSSL\lib" /LIBPATH:"%PROGPATH%\Mega-Nerd\libsndfi
    le\lib" /LIBPATH:"\dev\Boost\lib" /LIBPATH:"\dev\protobuf-2.5.0\vsprojects\Relea
    se" /LIBPATH:"..\..\release" /LIBPATH:"%PROGPATH%\ZeroC\Ice-3.5.1\lib\vc100" /LI
    BPATH:"r:\dev\QtMumble\lib" /DEBUG /OPT:REF /OPT:ICF /NOLOGO /DYNAMICBASE /NXCOM
    PAT /INCREMENTAL:NO /SafeSEH /NXCOMPAT /DYNAMICBASE /LTCG /MANIFEST /MANIFESTFIL
    E:"release\murmur.intermediate.manifest" /SUBSYSTEM:WINDOWS "/MANIFESTDEPENDENCY
    :type='win32' name='Microsoft.Windows.Common-Controls' version='6.0.0.0' publicK
    eyToken='6595b64144ccf1df' language='*' processorArchitecture='*'" /VERSION:1.25
     /OUT:..\..\release\murmur.exe @C:\Users\ACCT_~1\AppData\Local\Temp\nm2252.tmp

    MurmurIce.obj : error LNK2001: unresolved external symbol "__declspec(dllimport)
     public: __thiscall IceInternal::Cpp11FnCallbackNC::Cpp11FnCallbackNC(class std:
    :tr1::function<void __cdecl(class IceUtil::Exception const &)> const &,class std
    ::tr1::function<void __cdecl(bool)> const &)" (__imp_??0Cpp11FnCallbackNC@IceInt
    ernal@@QAE@ABV?$function@$$A6AXABVException@IceUtil@@@Z@tr1@std@@ABV?$function@$
    $A6AX_N@Z@34@@Z)
    ..\..\release\murmur.exe : fatal error LNK1120: 1 unresolved externals
    NMAKE : fatal error U1077: 'link' : return code '0x460'
    Stop.
    NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 10.0
    \VC\BIN\nmake.exe"' : return code '0x2'
    Stop.
    NMAKE : fatal error U1077: 'cd' : return code '0x2'
    Stop.

I had to get a little hacky in order to get this far. I installed Ice to default location. Version number didn't match that in winpaths_default.pri - so I modified it (I won't check it in :)). But then it kept failing to find Ice.lib. I ended up having to rename /lib/vc110/ into /lib/vc100. Then I got a lot further - but failed above.

I had previously set the following options:

qmake CONFIG-=sse2 CONFIG+=no-asio CONFIG+=no-g15 CONFIG+=no-bonjour CONFIG+=no-elevation -recursive

Any guidance? Thanks!

(btw I'm building release, if it matters..)