ServerDB: Database driver QSQLITE not available

Help
Devicated
2013-05-28
2013-05-31
  • Devicated

    Devicated - 2013-05-28

    I'm using Arch Linux ARM on a Raspberry Pi. I installed murmur using
    pacman -Sy murmur. After trying to start the murmur daemon I get the
    following error:

    [root@alarmpi /]# murmurd -ini /etc/murmur.ini -supw xxxxx
    <W>2013-05-28 15:54:13.773 Initializing settings from /etc/murmur.ini (basepath /etc)
    <W>2013-05-28 15:54:13.788 OpenSSL: OpenSSL 1.0.1e 11 Feb 2013
    <W>2013-05-28 15:54:13.794 SSL: Adding recommended CA StartCom Certification Authority
    <W>2013-05-28 15:54:13.800 SSL: Adding recommended CA AAA Certificate Services
    <W>2013-05-28 15:54:13.807 SSL: Adding recommended CA UTN-USERFirst-Client Authentication and Email
    <C>2013-05-28 14:54:13.809 Successfully switched to uid 86
    <F>2013-05-28 14:54:13.813 ServerDB: Database driver QSQLITE not available
    

    I'm assuming something is wrong with my Qt installation, but Qt was
    automatically installed by pacman. In /usr/lib/qt4/plugins/sqldrivers
    there are several files, one of which is libqsqlite.so. Is it possible
    the Qt-package in the Arch Linux ARM package database was not compiled
    with a qsqlite flag? Has anyone encountered this error before who knows
    how to fix this? Any help is greatly appreciated!

     
    Last edit: Devicated 2013-05-28
  • Devicated

    Devicated - 2013-05-31

    Alright, apparently the problem lies in running the process as a non-root user. Removing the user-id from the murmur.ini file fixed it. It runs as root now though, so that might be insecure...

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks