Unable to connect to server

Help
Demyze
2014-06-17
2014-06-17
  • Demyze

    Demyze - 2014-06-17

    I'm hosting my own server on fedora 20. I am able to connect to the server locally. I can not connect to the server from the LAN and from WAN.

    Here is the log file:
    <W>2014-06-17 09:22:55.843 Initializing settings from /etc/mumble-server.ini (basepath /etc)
    <W>2014-06-17 09:22:55.844 OpenSSL: OpenSSL 1.0.1e-fips 11 Feb 2013
    <C>2014-06-17 09:22:55.844 Successfully switched to uid 989
    <W>2014-06-17 09:22:55.868 ServerDB: Opened SQLite database /var/lib/mumble-server/mumble-server.sqlite
    <W>2014-06-17 09:22:55.871 Resource limits were 0 0
    <W>2014-06-17 09:22:55.871 Successfully dropped capabilities
    <W>2014-06-17 09:22:55.877 DBus registration succeeded
    <W>2014-06-17 09:22:55.881 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running
    <W>2014-06-17 09:22:55.883 OSInfo: Failed to execute lsb_release
    <W>2014-06-17 09:22:55.884 Murmur 1.2.6 (1.2.6) running on X11: Linux 3.11.10-301.fc20.x86_64: Booting servers
    <W>2014-06-17 09:22:56.023 1 => Server: TCP Listen on [::]:64738 failed: The bound address is already in use
    <W>2014-06-17 09:22:56.147 1 => Stopped
    <C>2014-06-17 09:23:10.562 Caught SIGTERM, exiting
    <W>2014-06-17 09:23:10.562 Killing running servers
    <W>2014-06-17 09:23:10.562 Shutting down
    <W>2014-06-17 09:23:10.563 MurmurIce: Shutdown complete
    <W>2014-06-17 09:23:14.711 Initializing settings from /etc/mumble-server.ini (basepath /etc)
    <W>2014-06-17 09:23:14.712 OpenSSL: OpenSSL 1.0.1e-fips 11 Feb 2013
    <C>2014-06-17 09:23:14.712 Successfully switched to uid 989
    <W>2014-06-17 09:23:14.736 ServerDB: Opened SQLite database /var/lib/mumble-server/mumble-server.sqlite
    <W>2014-06-17 09:23:14.739 Resource limits were 0 0
    <W>2014-06-17 09:23:14.739 Successfully dropped capabilities
    <W>2014-06-17 09:23:14.745 DBus registration succeeded
    <W>2014-06-17 09:23:14.749 MurmurIce: Endpoint "tcp -h 127.0.0.1 -p 6502" running
    <W>2014-06-17 09:23:14.751 OSInfo: Failed to execute lsb_release
    <W>2014-06-17 09:23:14.752 Murmur 1.2.6 (1.2.6) running on X11: Linux 3.11.10-301.fc20.x86_64: Booting servers
    <W>2014-06-17 09:23:14.903 1 => Server listening on [::]:64738
    <W>2014-06-17 09:23:15.048 1 => Announcing server via bonjour
    <W>2014-06-17 09:23:15.057 Object::connect: No such slot MurmurDBus::userTextMessage(const User *, const TextMessage &)

    I've already opened the ports on my router. Any thoughts? If you need any other files let me know.

     
    • mumblenz

      mumblenz - 2014-06-17

      I'm not real familiar with fedora (I've only ever run it on a Raspberry Pi). But does it use IPtables or have a firewall on by default?

       
  • Zheny

    Zheny - 2014-06-17

    hello,
    you should realize 2 network captures (client and server) to see of or comes the probleme.