Microphone Echo

  • Anonymous - 2010-09-10

    Recently bought a Mionix Keid 20 headset and as soon as soon as I started
    talking on mumble other users complained of echo.
    I then tested it on other VOIP apps like skype and steam chat and found that
    the echo was gone.
    I have echo disabled in the voice input. I am unsure of my soundcard it is
    just displayed as ATI high definition audio device.
    Feel free to ask for more info.

    Any help would be appreciated.

  • Nicos Gollan

    Nicos Gollan - 2010-09-10

    Make sure the right device is selected for recording. In Windows 7 and Vista,
    you need to set up the right communications device. Do not use "Mix",
    "Monitor", "What U Hear", or anything else with output mixed in.

    In Win7, search for "Manage audio devices", go to the Recording tab, mark the
    appropriate input, and choose "Set default / Default Communication Device"
    below the list.

  • Anonymous - 2010-09-10

    Yes I know about that. The other people can hear me clear it's just the echo.
    Another thing I just discovered is that when I play music they can hear it
    through mic as well as my voice.
    Definetely dont have stereo mix enabled either.

  • Nicos Gollan

    Nicos Gollan - 2010-09-10

    First, a potential "hardware fix": if you are using the front audio connectors
    on your case for the microphone input, try the jacks on the back of the case,
    and see if that helps. I've seen it more than once that the front connectors
    have such a bad connection to the sound chip that the output signal gets
    induced to the microphone lines. Mumble's very sensitive SNR voice activation
    then recognizes that immission as voice, and transmits it back. (I've had that
    effect without the microphone even connected to the case...).

    If you still get the effect then, and are using voice activation, try setting
    it to amplitude-based, and set that up to work properly (you need to check the
    "advanced" checkbox on the bottom left of the settings dialog).

  • Nicos Gollan

    Nicos Gollan - 2010-09-10

    Addendum: you may need to completely disconnect the front panel jacks from the
    board to have an effect, depending on the hardware routing, but just try the
    back jacks first.

  • Anonymous - 2011-01-18

    Same problem here. Googletalk or Skype works great, with no echo. We've tried
    everything, different mics, different settings, etc..

    Mumble.. get that fixed!!

  • Eventide7

    Eventide7 - 2011-02-12

    I don't know if this will help, but I was having a similar problem. I ended up
    going into my sound control panel for my OS and turning the microphone almost
    all the way down. Mumble was then able to handle the sound coming through,
    boosting it to the appropriate levels, without picking up all the surrounding
    sound pollution and creating a feedback loop.

  • Kostas Katsaros

    Kostas Katsaros - 2013-07-28

    For every (X)Ubuntu 12.04 user that may watch this. This is known bug for 12.04:
    "Mumble echo cancellation is completely broken on Precise"
    The solution that worked for me was using Pulse Audio echo instead of the Mumble's one.
    I copy from Colin S. on the above bug report (much appreciated!):

    I found a workaround which uses PulseAudio's own echo canceller instead of Mumble's. For it to work, you must use PulseAudio for your sound input and output. From the console,
    $ pactl load-module module-echo-cancel
    This command will create another PulseAudio sink/source pair for echo cancellation, named "Echo-Cancel Source xxxx" and "Echo-Cancel Sink xxxx." Select these in Mumble for your sound input and output devices. Be sure to disable Mumble's echo cancellation. (Set "Echo" to "Disabled" in your Audio Output preferences.) This works much better than Mumble's own echo canceller on Precise.

    • Colin S.

      Colin S. - 2013-08-11

      "Mumble echo cancellation is completely broken on Precise"

      One addendum to this fix: The module-echo-cancel includes an AGC loop to automatically adjust your microphone volume to the optimal level. The problem is, so does Mumble. The dueling AGC loops may result in big fluctuations in volume, and it may also cause your voice activity detector to trip spuriously. To help combat this, you may want to turn off "noise suppression" and set your "max amplification" to 1.0 in mumble's Audio Input preferences.

      I really think that the echo cancellation should be done in PulseAudio itself. The PA echo canceler runs with real-time scheduling priority and includes synchronization to cope with big delays between input and output streams. Both of these things are a must-have for acoustic echo cancellation. I've tested Mumble with several Ubuntu machines and setups, and I've never gotten its echo canceler to do anything useful. The PA canceler always seems to work, however.