Vaithiyanathan - 2013-04-05

I am using Mumble for a research. I have completed my modifications and the nmake debug is working well. I could run the mumble.exe inside debug folder and see the modifications working. However, when I ran nmake release the nmake fails.

The following error occurs:

LINK : fatal error LNK1181: cannot open input file 'speex.lib'

NMAKE : fatal error U1077: 'link' : return code '0x49d'

I tried several work around and fell into other problems:
1. I tried changing the Mumble.pro. I changed the LIB path for speex.lib from speex.lib to ....\debug\speex.lib. --> I got opus.lib missing error.
2. Then I tried changing the lookup directory for both speex.lib and opus.lib ---> I could generate mumble.exe but was missing speex.dll, opus.dll, mumble_ol.dll, etc. I copied those dlls from debug and tried running the release .exe. --> I ended up getting "Referral was sent from Server" error.

I really need to build mumble and use the .exe file in two of my other computers as a part of my research. Please help. Awaiting your response.

Thanks in advance.