Murmur does not read from murmur.ini

Help
HHL
2013-05-23
2013-05-24
  • HHL
    HHL
    2013-05-23

    Hi,

    I've setup a murmur server on a windows server 2012 (virtual machine).
    However it does not load it's settings from the murmur.ini, instead using default settings.
    Mumble + murmur is installed in the default directory under c:\ProgramFiles (x86)\Mumble
    I've managed to set the superuser password and the server seems to work fine regarding anything else.
    Could it be a syntax error or a windows server thing?
    I feel like i'm missing something obvious but I'm really at a loss.
    Any help/suggestions would be appreciated.

    regards

    HHL

     
    Last edit: HHL 2013-05-23
  • Mikkel Krautz
    Mikkel Krautz
    2013-05-23

    Can you see from the log whether it's using the correct .ini file?

    How do you determine that it's not using the settings from the .ini? Some of the settings are merely defaults, and will not affect a given virtual server after it's created if the virtual server has values for the config keys already in its DB.

    Either way, you can explicitly specify the .ini path by using the "-ini <inifile>" parameter to murmur.ini (but watch for spaces in the filename if you specify it absolutely).

     
    • HHL
      HHL
      2013-05-24

      I managed to get it to work by editing the .ini file in notepad ++.
      (It was probably an extension error or something silly like that)

      To answer your questions the log file showed it did use the right filepath and i came to the conclusion it didn't read the .ini file because i had edited the serverpassword, welcometext and registerName, none of which were present on the server. (now they are)
      Thanks for the quick reply.

      regards

       
      Last edit: HHL 2013-05-24