Cannot connect to ANY server - Connect is Disabled.

  • Chris

    Chris - 2014-03-05

    I have a friend who cannot get Mumble to connect to any public or private servers because her connect button is disabled. I thought there might be a problem with her router or ISP, but her son’s computer connects without a problem.

    I have verified that she has the correct server information. She has successfully pinged the server and can see the number of people online, but the connect button is still disabled.

    I had her run the Certificate Wizard, but that didn’t have any effect.

    I verified she has the latest version and have had her run the Audio Wizard.

    Short of an uninstall/reinstall, which she said she has tried, I’m out of ideas. Does anyone else have any?

    Thanks for your help!

  • Stefan H.

    Stefan H. - 2014-03-05

    As soon as Mumble is able to resolve the name of the server the connect button is enabled. If doesn't enable this usually means that either the server address given is incorrect or DNS resolution failed for some reason.

    Seeing ping information (usercount etc.) without a previous successful name resolution shouldn't be possible. A ping is only started after successful name resolution so I'm not sure I understand your second paragraph correctly.

    The wizards don't affect the connect dialog in any way.

    If the information is correct and name resolution works on this system you could try turning of QoS in the advanced configuration and see if that makes things work. Broken routers/drivers sometimes choke on packages trying to employ Quality of Service.

  • Chris

    Chris - 2014-03-06

    Sorry, I forgot to mention that we already tried turning off QoS. Next time we try to get it to work, I'll verify that it is off.

    In regards to my second paragraph, the Server Connection window has both Ping and Users columns, both of which are returning values. So to me that means that the server name is correct, since the server is responding to a ping and is notifying her how many people are on the server at that moment. But as you said, if the server name is correct, it should be enabling the Connect button. Also, I had her manually ping the server with DOS prompt without issue.

    She also isn't able to connect to the preloaded public servers that come with Mumble. Since she can't connect to anything, I doubt it's the server name.

    I've had her verify that Windows Firewall isn't blocking Mumble and I've had her load Mumble as an Administrator, both which didn't work. I think I'm going to ask her to let me use a Remote Desktop of some type (probably Skype) so I can actually see what she has going on.

    Thanks for the help. If you or anyone else can think of anything, please let me know. If I can figure it out, I'll be sure to mention what the problem is.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks