Server connection failed: Connection refused.

  • Nicholas Solin

    Nicholas Solin - 2009-12-15

    I installed the static version (murmur.x86) of Murmur to /opt/murmur, made the
    files chown -R murmur:root, along with chmod 775 (/var/run/ has the
    same permissions), but when I try to connect to my Murmur server from the PC
    in my LAN, I receive the error mentioned in the title. Here is my murmur.ini:

    Path to database. If blank, will search for

    murmur.sqlite in default locations or create it if not found.


    If you wish to use something other than SQLite, you'll need to set the name

    of the database above, and also uncomment the below.

    Sticking with SQLite is strongly recommended, as it's the most well tested

    and by far the fastest solution.








    Murmur defaults to not using D-Bus. If you wish to use dbus, which is one of


    RPC methods available in murmur, please specify so here.


    Alternate service name. Only use if you are running distinct

    murmurd processes connected to the same D-Bus daemon.


    If you want to use ZeroC ICE to communicate with Murmur, you need

    to specify the endpoint to use. Since there is no authentication

    with ICE, you should only use it if you trust all the users who have

    shell access to your machine.

    Please see the ICE documentation on how to specify endpoints.

    ice="tcp -h -p 6502"

    How many login attempts do we tolerate from one IP

    inside a given timeframe before we ban the connection?

    Note that this is global (shared between all virtual servers), and that

    it counts both successfull and unsuccessfull connection attempts.

    Set either Attempts or Timeframe to 0 to disable.

    autobanAttempts = 10

    autobanTimeframe = 120

    autobanTime = 300

    Murmur default to logging to murmur.log. If you leave this blank,

    murmur will log to the console (linux) or through message boxes (win32).


    If set, murmur will write its process ID to this file.


    The below will be used as defaults for new configured servers.

    If you're just running one server (the default), it's easier to

    configure it here than through D-Bus or Ice.

    Welcome message sent to clients when they connect

    Welcome to this server running Murmur.
    your stay!

    Port to bind TCP and UDP sockets to


    Specific IP or hostname to bind to.

    If this is left blank (default), murmur will bind to all available


    Password to join server


    Maximum bandwidth (in bits per second) clients are allowed

    to send speech at.


    Maximum number of concurrent clients allowed.


    Regular expression used to validate channel names

    (note that you have to escape backslashes with \ )


    Regular expression used to validate user names

    (note that you have to escape backslashes with \ )


    Maximum length of text messages in characters. 0 for no limit.


    Allow clients to use HTML in messages, user comments and channel


    Murmur retains the per-server log entries in an internal database which

    allows it to be accessed over D-Bus/ICE.

    How many days should such entries be kept?


    To enable public server registration, the serverpassword must be blank, and

    this must all be filled out.

    The password here is used to create a registry for the server name;


    updates will need the same password. Don't lose your password.

    The URL is your own website, and only set the registerHostname for static IP


    registerName=Mumble Server




    To enable bonjour service discovery uncomment the following line.

    To change the name announced by bonjour adjust the registerName variable.

    See [](http://develo for more information

    about bonjour.


    If you have a proper SSL certificate, you can provide the filenames here.



    To enable username registration through



    then this value must be set to a valid email

    and you must be running a SMTP server on this


    This option is only used for a pre-packaged system-wide installation,

    and does nothing if you just start murmurd yourself.


    If murmur is started as root, which user should it switch to?

    This option is ignored if murmur isn't started with root privileges.


    If this options is enabled, only clients which have a certificate are


    to connect.


    You can configure any of the configuration options for Ice here. We


    leave the defaults as they are.

    Please note that this section has to be last in the configuration file.


  • Dirk Krüger

    Dirk Krüger - 2009-12-15

    Im shure you checked that mumur is runnung:

    ps -ef | grep murmur

    Could you please paste your latest tail of the "logfile=murmur.log" ?

    Can you try to install a mumble client on the serversystem to check it isnt
    some sort of Firewall thingy?

    Try to set the superuser Password and connect using the SuperUser.

    can you try a telnet seesion on port 64738. (not that it works, but just to
    see if there is something listening on the server)

  • Nicholas Solin

    Nicholas Solin - 2009-12-15

    I know Murmur has been running because I have been using kill -9 to kill the
    process by finding it in Gnome's System Monitor, but for the purpose of

    ps -ef | grep murmur

    murmur 7941 1 0 16:01 ? 00:00:00 ./opt/murmur/murmur.x86
    root 7943 7912 0 16:01 pts/4 00:00:00 grep murmur

    And the murmur.log:

    <W>2009-12-13 01:52:14.931 Initializing settings from /opt/murmur/murmur.ini
    (basepath /opt/murmur)
    <W>2009-12-13 01:52:14.931 Binding to address
    <W>2009-12-13 01:52:14.985 SSL: Added CA certificates from '/etc/pki/tls/certs
    <C>2009-12-13 01:52:14.992 Successfully switched to uid 105
    <W>2009-12-13 01:52:14.993 ServerDB: Openend SQLite database
    <W>2009-12-13 01:52:14.996 Resource limits were 0 0
    <W>2009-12-13 01:52:14.997 Successfully dropped capabilities
    <W>2009-12-15 02:58:54.352 Initializing settings from /opt/murmur/murmur.ini
    (basepath /opt/murmur)
    <W>2009-12-15 02:58:54.355 Binding to address
    <W>2009-12-15 02:58:54.409 SSL: Added CA certificates from '/etc/pki/tls/certs
    <C>2009-12-15 02:58:54.416 Successfully switched to uid 105
    <W>2009-12-15 02:58:54.417 ServerDB: Openend SQLite database
    <W>2009-12-15 02:58:54.420 Resource limits were 0 0
    <W>2009-12-15 02:58:54.420 Successfully dropped capabilities
    <W>2009-12-15 03:02:55.459 Initializing settings from /opt/murmur/murmur.ini
    (basepath /opt/murmur)
    <W>2009-12-15 03:02:55.465 Binding to address
    <W>2009-12-15 03:02:55.517 SSL: Added CA certificates from '/etc/pki/tls/certs
    <C>2009-12-15 03:02:55.524 Successfully switched to uid 105
    <W>2009-12-15 03:02:55.525 ServerDB: Openend SQLite database
    <W>2009-12-15 03:02:55.528 Resource limits were 0 0
    <W>2009-12-15 03:02:55.528 Successfully dropped capabilities
    <W>2009-12-15 16:01:26.089 Initializing settings from /opt/murmur/murmur.ini
    (basepath /opt/murmur)
    <W>2009-12-15 16:01:26.092 Binding to address
    <W>2009-12-15 16:01:26.168 SSL: Added CA certificates from '/etc/pki/tls/certs
    <C>2009-12-15 16:01:26.178 Successfully switched to uid 105
    <W>2009-12-15 16:01:26.197 ServerDB: Openend SQLite database
    <W>2009-12-15 16:01:26.201 Resource limits were 0 0
    <W>2009-12-15 16:01:26.211 Successfully dropped capabilities

    I am positive that port 64738 is past my firewall on my server (firewall is
    iptables) as both UDP and TCP. I do not know if I can install the Mumble
    client on Linux can I? Don't I have to compile that from scratch?

    I set the SuperUser password:

    cd /opt/murmur

    ./murmur.x86 -supw **

    Initializing settings from /opt/murmur/murmur.ini (basepath /opt/murmur)
    Binding to address
    SSL: Added CA certificates from '/etc/pki/tls/certs/ca-bundle.crt'
    Successfully switched to uid 105
    ServerDB: Openend SQLite database /opt/murmur/murmur.sqlite
    Superuser password set on server 1

    I tried to connect to my running Murmur server in HyperTerminal and it

    Unable to connect to on 64738

  • Tom Pryor

    Tom Pryor - 2009-12-16

    You're binding to (or localhost.localdomain as you've put in your
    config). This will only allow connections from the machine murmur is running
    on which is obviously not what you want. Change host in your mumur.ini to to bind to all available address or to to just listen on
    that IP (Be careful if you are using DHCP as your server might get a different
    IP address and you'll encounter the same issue)

  • Nicholas Solin

    Nicholas Solin - 2009-12-19

    Well if you saw my first run in the murmur.log, I tried binding to
    and I still received this message.

    I had to wipe my server since last I posted, I have reinstalled murmur and
    upon first execution:

    ./murmur.x86 -fg -v

    Initializing settings from /opt/murmur/murmur.ini (basepath /opt/murmur)
    Binding to address
    SSL: Added CA certificates from '/etc/pki/tls/certs/ca-bundle.crt'
    Successfully switched to uid 503
    ServerDB: Openend SQLite database /opt/murmur/murmur.sqlite
    Generating new tables...
    Resource limits were 0 0
    Successfully dropped capabilities

    I ended the process and then set my SuperUser password:

    ./murmur.x86 -supw **

    Initializing settings from /opt/murmur/murmur.ini (basepath /opt/murmur)
    Binding to address
    SSL: Added CA certificates from '/etc/pki/tls/certs/ca-bundle.crt'
    Successfully switched to uid 503
    ServerDB: Openend SQLite database /opt/murmur/murmur.sqlite
    Superuser password set on server 1

    Then I restarted my server. At first I had:

    Server connection failed: Connection timed out.

    Because I forgot to add the port to my firewall, then I added it to my
    firewall and now I have:

    Server connection failed: Connection refused.

    Again. When I ran it as a normal daemon:


    I had this in my murmur.log:

    <W>2009-12-19 00:24:15.466 Initializing settings from /opt/murmur/murmur.ini
    (basepath /opt/murmur)
    <W>2009-12-19 00:24:15.466 Binding to address
    <W>2009-12-19 00:24:15.519 SSL: Added CA certificates from '/etc/pki/tls/certs
    <C>2009-12-19 00:24:15.526 Successfully switched to uid 503
    <W>2009-12-19 00:24:15.527 ServerDB: Openend SQLite database
    <W>2009-12-19 00:24:15.530 Resource limits were 0 0
    <W>2009-12-19 00:24:15.530 Successfully dropped capabilities

    So I have no idea why I cannot make a connection.

  • Nicholas Solin

    Nicholas Solin - 2009-12-23

    Alright, how about I just ask developer-esqe questions and go through this
    step-by-step to figure out why I cannot run Murmur.

    The first five lines in the start-up make sense, just opening murmur.ini,
    binding to an address, importing certificates, switching the user, and opening
    the database.

    As per the last two lines, what do they mean:

    <W>2009-12-19 00:24:15.530 Resource limits were 0 0

    Should me resource limits be 0 0?

    <W>2009-12-19 00:24:15.530 Successfully dropped capabilities

    Should it drop capabilities?

    Also, what outside libraries does Murmur use? I know it runs primarily on QT4,
    but on CentOS all my programs depend on QT3.3, even though I have both

    Could Murmur be making calls to QT3.3 and it cannot process them?

  • Tom Pryor

    Tom Pryor - 2009-12-23

    I've no idea what those messages actually mean but I also get "Resource limits
    were 0 0" when starting murmur but rather than dropping capabilities mine just
    says "Failed to set final capabilities" which sounds worse than the message
    you are getting but I've no idea what it actually means - Guess you'll need a
    developer to clarify on these messages.

    As for the QT stuff the static linux server is precisely that - static.
    Therefore it does not dynamically load libraries as they are already compiled
    "inside" the final application (murmur.x86). Murmur has all the parts of the
    libraries it needs to run already "inside" of it so it should not be making
    external library calls.

    However, one difference I've noticed between your log and mine:

    <W>2009-12-23 08:59:52.892 Initializing settings from /mumble/murmur.ini
    (basepath /mumble)
    <W>2009-12-23 08:59:54.342 SSL: Added CA certificates from '/etc/pki/tls/certs
    <C>2009-12-23 08:59:54.350 Successfully switched to uid 501
    <W>2009-12-23 08:59:55.357 ServerDB: Openend SQLite database
    <W>2009-12-23 08:59:55.381 Resource limits were 0 0
    <C>2009-12-23 08:59:55.395 Failed to set final capabilities
    <W>2009-12-23 08:59:55.950 Failed to connect to D-Bus session
    <W>2009-12-23 08:59:57.562 MurmurIce: Endpoint "tcp -h -p 6502"
    <W>2009-12-23 08:59:57.563 OSInfo: Failed to execute lsb_release
    <W>2009-12-23 08:59:57.564 Murmur 1.2.0 (Compiled Dec 10 2009 20:04:38)
    running on X11: Linux 2.6.18-028stab064.4: Booting servers
    <W>2009-12-23 09:00:20.318 0 => Binding to address
    <W>2009-12-23 09:00:25.713 0 => Server listening on
    <W>2009-12-23 09:00:28.616 0 => Announcing server via bonjour
    <W>2009-12-23 09:00:30.828 0 => Not registering server as public
    <W>2009-12-23 09:00:31.476 1 => Binding to address
    <W>2009-12-23 09:00:33.424 1 => Server listening on
    <W>2009-12-23 09:00:34.273 1 => Announcing server via bonjour
    <W>2009-12-23 09:00:34.683 1 => Not registering server as public

    Goes on to boot rest of servers...

    Is that it your log never gets past the capabilities thing. Now, I'm not sure
    if this is because I use virtual servers or not but I noticed you are using
    dbus and I would guess it would say something about that (In my case it says
    that it can't use dbus but I guess it would say something about using dbus in
    your log). Can you manage murmur via dbus? Try disabling it (Ice is better
    anyway ;D)

  • Nicholas Solin

    Nicholas Solin - 2009-12-24

    Thank you tomdarkness I can finally host a murmur server! w00t!

    The problem was dbus, when I had dbus=session uncommented it froze the server,
    I commented it out and it works like a charm now.

    I am still going to try to build murmur though so I can compare the optimized
    version with the static. Who knows, it might be better.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks