Continous and random problems with Mumble!

  • Painfury

    Painfury - 2010-11-28

    Right so my main problem is that at random intervals my Mumble simply stops
    functioning as it should. It doesn't shut down or disconnect or even say
    anything to notify me that this has happened, but when I speak no one can hear
    me, and when others speak I can't hear them. The only solution is to
    continuously restart Mumble which is very tiring and inefficient. There is no
    problem with my internet (I run a game while this happens so I'm sure it isn't
    getting disconnected), my mic works fine before the random errors, and even
    during when I go to the setup wizard I can hear myself, my speakers are
    functioning as well as I can hear myself in the setup wizard during the

    I have tried reinstalling the software, and even downloaded it again just to
    make sure I didn't get a faulty version...Would extremely appreciate any
    possible help

  • Filmore

    Filmore - 2010-12-16

    I seem to have the same problem, while mumble does not appear to close down
    all communicatio between me and the rest of the people is stopped. No
    connection problems, microphone and speakers work. Mumble just seems to do
    this -very- frequently for me, sometimes less than 20 secons from the
    reconnect to get it working again.

    Rather frustrating.

  • Terrox

    Terrox - 2010-12-26

    i got this problem to, i can hear user connecting and disconnecting, but not
    hear anyone speak, or anyone hear me speak. really annoying especialy if
    you're playing a game.
    and as the others said, reconnecting works, but not for long.

  • Nicos Gollan

    Nicos Gollan - 2010-12-26

    First, the most basic troubleshooting: run the audio wizard. You should be
    able to hear yourself talking in the input steps. When connected to the
    server, open the settings dialog, enable "advanced" settings, and select
    server loopback in the audio output settings. You should be able to hear
    yourself when connected to a server.

    When that happens on an otherwise working server, it's usually an issue with a
    firewall or a generally wonky router.

    Make sure you're not blocking UDP packets going to or coming from the port the
    server is using.
    In the advanced client settings, go to Network, and disable "Use Quality of
    Service". Apply changes, reconnect, and check if that helps.
    Disable personal firewall software, or firewall features on the router. Check
    if there's "stateful packet inspection" or "heuristic" filtering features, or
    things like "DoS protection", and disable those.
    Check if there's a firmware upgrade for your router.
    In the advanced client settings, go to Network, and enable "Force TCP mode".
    Apply changes, reconnect, and check if that helps.

  • Anonymous

    Anonymous - 2010-12-27

    Since trying out the latest 1.2.3 snapshot, I am experiencing the same
    problems. I know for a fact I have no TCP/UDP problems (the server is in the
    same network), yet after some indeterminate time, my mumble client will not
    transmit audio. I change no settings, and closing/re-starting Mumble clears
    the issue. Very annoying.

  • Anonymous

    Anonymous - 2010-12-27

    To clarify, it always works initially, but has some random chance to stop
    working later.

  • Kissaki

    Kissaki - 2011-01-02

    Even with client and server in the same network there can still be networking
    issues through hardware and software firewalls.

    Is the speaking still registered, the talking icon showing?

    I'd also suggest try running TCP mode.
    For further troubleshooting install and run Wireshark to track network
    packages. (portable versions available as well)
    Check if packets are still sent, transmitted and/or received.

    One of you said it's sometimes ~20 s until issue. How long for you others? How
    long typically, min and max?
    Is it maybe when you start a game, the game loaded 3d engine, or started
    playing the first sound? Anything like that?
    Or maybe it is when someone new connects? Someone specific is in the same
    channel? (client and codec versions and/or switching/fallback)

    You may also want to try 40 or 60ms jitter buffer if you're using a low one,
    or different codec quality for mumbles audio.

  • Stuart A.

    Stuart A. - 2011-01-13

    Same here. I am almost at the point where I can't use mumble anymore because i
    have to alt-tab out of my fullscreen games to fix this ALL THE DAMN TIME. Its
    annoying beyond belief.
    Windows XP
    AMD Athlon X64 +5200 @ 2.6 GHz

  • Benjamin Jemlich

    Please post the contents of the mumble.log file for a run where that problem
    happened (using the latest snapshot). I'm not sure if it contains something
    useful but it might be worth too look at it.

  • Nicos Gollan

    Nicos Gollan - 2011-01-31

    Voice cutting out completely at seemingly random times sounds like the 1.2.2
    server issue with codec negotiation. If that's the cause, using a 1.2.3
    snapshot server would help.

  • Anonymous

    Anonymous - 2011-03-13

    Rather than go mad trying to figure this out (yet another person having this
    issue in 1.2.3) I just want to go back to the working 1.2.2

    Where will I find that?

  • Anonymous

    Anonymous - 2011-04-02

    I've been having the same problem now for quite some time. It only happens
    when my computer has been on for about a day or more, and once it starts it
    happens more and more frequently. Only way to fix it is by restarting mumble
    or my entire computer for a slightly prolonged fix. Very, very annoying.

  • Ryker

    Ryker - 2012-01-29

    created an account to post. confirming this issue makes mumble unuseable. it
    seems like it cuts out whenever communications go silent for too long, but
    maybe im crazy. any workaround would be appreciated and rewarded with applause
    and a compliment.

  • Nicos Gollan

    Nicos Gollan - 2012-01-29

    If you see the problem only after very long stretches of inactivity, it's
    possible that the port translation gets dropped by the NAT implementation of
    your home router. I don't know if the client does any kind of keepalive, but
    it might be a useful feature.

  • Terrox

    Terrox - 2012-02-07

    ok, it was kinda far since i posted last time but i forgot about it (2 years
    but to clarify my problem.
    Mumble sometimes starts to work slow/not respond as on my computer.
    I can always hear the other as they speak, but for myself there can be delays
    from when i push my ptt and untill i actually speak (i have the ptt noise on
    so i can hear when its happening). And under the delay between the button push
    and when i start to speak the mumble window is unresponsive (i can still hear
    other speak though).
    And its the same when i release the button to, takes a while for mumble to
    stop speaking after a while i released the button. The computer always works
    in normal speeds under the problems. and it can happend no matter what program
    im using, all from desktop to gaming.
    And its nothing on the internet or anything, its the mumble program that
    starts to act only.
    And as far as i remember i have tried your suggestions you mentioned in post 4

  • Anonymous

    Anonymous - 2012-04-02

    I had the same problem, it followed me through two diffrent computers and thru
    win xp, vista, ubuntu and win 7. One day I was pissed as hell on a thing and i
    slamed my headphones down on the desk, they shatered to pieces and i bought a
    new set. I have never had that problem again.

  • Anonymous

    Anonymous - 2012-04-02

    was that creative fatality gaming headset btw

  • Anonymous

    Anonymous - 2012-08-01

    My brother has this problem at the moment but I don't and we are on the same
    network. We have the same OS (win7) and same headset (Logitech G35). He gets
    deafened and muted after 30-60 seconds then he has to restart mumble.

  • Cathzilla

    Cathzilla - 2012-09-13

    I am having this exact same issue. Only popped up after moving to campus and I
    started using the horrible internet in the dorms. The sound will cut out after
    a period of quiet like omnipotant said.

  • Nicos Gollan

    Nicos Gollan - 2012-09-13

    If it happens after a longer period without voice transmission, it could be
    that some intermediate NAT router drops the port translation for UDP. If you
    are on such a horrible network, using TCP-only mode should help to some