Issues with SuperUser and related things

  • Samuel

    Samuel - 2012-09-22

    Hello, i'm going slightly insane here trying to figure this one out.

    I wanted to set up a quick mumble server for me and my friends to speak easily
    to eachothers while gaming. So i downloaded the install and installed
    mumble+murmur. Started the server and chose a password for the server in the
    .ini. Logged in without issues and my friends could also log in. Now i wanted
    to set up a couple of channels to separate us if we were doing different

    I did some reading and found out about SuperUser and Admins so i started to
    configure the SuperUser password thru cmd (running Win 7 here)
    - put myself in the C:\program files (x86)\mumble folder
    - did the mumbe.exe -ini "path to mumble.ini" supw pass and it got accepted.
    - next i logged out from the server and hit edit and tried to log in as SuperUser (yes i know it's case sensitiv) but the password i set is not accepted as the superuser password.

    Did i miss something during my initial playing around with the server? I have
    to use the autogenerated certificate to log in as the username i chose but i
    should be able to change that if i can get an admin account set up correct? So
    i would like to know why my password, wich i set following the guide is not
    accepted? SuperUser should disregard certificates anyway i think.

    Please please help me with this.

  • Lari Hartikainen

    When you connect to your server with admin rights first time you use SuperUser
    as login name and the password you made,
    When you create your own username and log to server you use Certificate "works
    like password" not password.

    But to the problem, first time you login SuperUser, right click the ROOT
    channel and select Edit, and on tab Groups
    select admin and there you can select Members for admins "if there is not
    admin Group press Add and make one,
    after that you go to tab ACL and at the User/Group section select Group
    "admin" and on right side you set Permissions for it,
    you can also use only @auth settings and give authed users Permissions to Make

    -ini -supw <password>
    Login: SuperUser
    Password: password
    and configure the ACL settings.

    hope this helps.

  • Samuel

    Samuel - 2012-09-24

    I knew how to set the SuperUser password that wasn't the issue, My problem was
    that the password i had set during that process wouldn't be recognized when
    logging in as SuperUser. I don't know why but the password i had chosen being
    8 characters with lowercase, uppercase and numbers didn't work but when i
    changed it to a password with only lowercase it did. So atleast that problem
    has now been solved. Thanks for the reply tho. Glad to see ppl can get help

    If someone knows why useres conencting to my server sometimes disconnect only
    to connect again so fast you can't even notice they are gone i'd love some
    answer. I'm hosting it from my homeconnection but that is a 100/100 fiber
    connection so it should be plenty for the 3-5 ppl using my server.

  • Lari Hartikainen

    Have checked servers logs? im hosting 2 virtualservers and on both haveing
    about 10 users at time maximum, and dont have problems, some times soe one has
    problem to connect to server but its usualy wrong client version used, ie like
    "07:21 PM<123:(-1)> Connection closed: Error during SSL handshake:
    error:1408A10B:SSL routines:SSL3_GET_CLIENT_HELLO:wrong version number " From
    my server log means user tryes to connect with mumble old backup version,
    should check that users use 1.2.3 version exe file, second thing might be some
    server settings,
    i had old times problem like yours, and fixed it by changeing
    bandwidth to 1200000 and see that your server has
    certrequired = Disabled

    if you need to get easy way to controll your server get php Mumble Admin from Recuires webserver, i use it all the time and is fast way
    to see if some one has problem to connect.

  • Samuel

    Samuel - 2012-09-26

    Looked at the murmur.log file and it's a mess of Timeouts.
    Here is a sample of the latest disconnect and reconnect but they all look like

    <W>2012-09-26 06:41:10.195 1 => <1:(-1)> Timeout
    <W>2012-09-26 06:41:23.296 1 => <9:(-1)> New connection:
    <W>2012-09-26 06:41:23.767 1 => <9:(-1)> Client version 1.2.3 (Win: 1.2.3)
    <W>2012-09-26 06:41:23.770 1 => <9:Mevos(-1)> Disconnecting ghost
    <W>2012-09-26 06:41:23.773 1 => <10:Mevos(-1)> Connection closed:
    <W>2012-09-26 06:41:23.776 1 => <9:Mevos(-1)> Authenticated
    <W>2012-09-26 06:41:24.386 1 => <9:Mevos(-1)> Moved Mevos:9(-1) to Guild Wars
    <W>2012-09-26 06:41:25.695 1 => <1:(-1)> Timeout

    Everyone is using latest 1.2.3 ver and certreq is set to false. Where do you
    change bandwidth?

  • Samuel

    Samuel - 2012-09-26

    nevermind, found the bandwidth. I'll give it a tweak and see if that clears it

  • Lari Hartikainen

    I think you can use higher Bandwith, i have only 100/10 fiber so i use 1200000
    (~120Kb/s) rate per server so my upload will be ~240Kb/s with mumble servers.