SourceForge has been redesigned. Learn more.

GlobalShortcutWin: CreateDevice: 80004005

  • UnderMiner

    UnderMiner - 2010-12-02

    GlobalShortcutWin: CreateDevice: 80004005
    The above message appears when I start Mumble client. I can chose to press OK
    and Mumble closes or I can do nothing about it and I can use Mumble normally.
    The message doesn't appear when using "Mumble (Backwards Compatible)" though
    If anyone has encountered the same problem and error code, and has found a fix
    for it, pls let me know.
    I believe it's due to my OS that I get the message seeing as it doesn't happen
    on x86 systems.

    My system:

    GigaByte GA-MA78GM-S2H
    AMD Phenom II X2 545
    2*2GB Kingston HyperX PC2-8500
    Windows XP Professional X64

    Mumble version:

  • Mr. Rawnar

    Mr. Rawnar - 2010-12-09

    The error code is very generic, to be more precise its name is DIERR_GENERIC.
    It means: "An undetermined error occured inside the DInput subsystem". Do you
    have any shortcuts defined to a device that is not attached or a input device
    that has poor support under your OS. Maybe you could try to detach some of
    your input device to see which one is given the problems.

  • UnderMiner

    UnderMiner - 2010-12-11

    I've tried unplugging every hardware, tried another keyboard and another mouse
    but I still get the same error message. Also tried uninstallinf other things
    (nokia pc suite, drivers, programs and such) to no avail.
    Other ideas are very welcome and thanks for answering my question rawnar

  • Mr. Rawnar

    Mr. Rawnar - 2010-12-13

    Could you be so kind to check if the message still pops up when running the
    latest snapshot.

  • UnderMiner

    UnderMiner - 2010-12-18

    It does. Uninstalled the old mumble, deleted leftover files and went through
    the registry. Installed the new mumble and murmur but still got the same error
    on startup of mumble.
    Guess I'll just have to move the error-box to the side of the screen and use
    mumble with it in the background cause, it does after all work when don't
    press the "ok" button in the box. Only thing that doesn't work is the "Push To
    Talk" feature.
    For now, I'll wait for a fix and if there's anything I can do to help
    (logging, try beta builds or other) I'd like to do that. Maybe I'm not the
    only one who has the problem.

  • Anonymous

    Anonymous - 2011-04-27

    I'm getting the same error code but I think I have it narrowed down to some
    sort of virtual device, either Winamp or Magic Disk.

  • Anonymous

    Anonymous - 2011-04-27

    Just confirmed it is not Winamp nor Magic Disk. When mine errors I can use it
    but it I touch the main window, I can't talk or hear anyone, which requires
    that I restart Mumble.

  • blakerobinson

    blakerobinson - 2011-05-01

    i get a similar error

    globalshortcutwin: setcooperativelevel: 80004001

    cant figure out what the problem is

  • MichaelFrie

    MichaelFrie - 2014-01-22

    I was receiving this error and it was due to the Push-to-talk hotkey created with was orinally my right ctrl on my keyboard... now it is listed at "k:unknown" on all keybinds or if on mouse "m:unknown" to remove the message simply remove the hotkeys by clicking remove... apply... ok... restart mumble in admin mode - as to the problem behind between the keyboard/mouse and not registering to mumble I'm not quite sure atm but will be looking into it - If a fix is discovered I will post it @ a later time.