Spencer - 2013-06-20

I have an AT2020 connected via USB to a Mountain Lion MacBook Pro running Mumble 1.2.4. Each time I connect to my work server, I have to hit 'apply' in the config panel in order for my mic to start working and allow others to hear me. This is becoming quite annoying to have to do this each time I start up Mumble. I've tried reinstalling Mumble and running the audio setup wizard with no change. My mic is currently set to "continuous" as my transmission option. Any help in making it so my mic auto transmits without having to open the settings and hit 'apply' or 'okay' in order to begin transmission each time I connect to a server would be much appreciated.