SkaterSam - 2014-02-11

I've asked this question several times to several groups without avail, but I just found out about this forum so I'm hoping you guys can help me. Now lets get to the problem:

I get a time out every single time I attempt to connect to a server that is running on the default port (64738), all the other ones work great it's just any server on that port will time out without fail. I know it's not blocked because I can see ping and user count I just can't connect to it.

Here is what I'm using:

Comcast internet
Mumble 1.2.4
Arch linux Manjaro to be exact also tried it on mint with the same result
i3, 8 gb computer (laptop)

Things I've tried:

Checking to make sure it's not blocked even though that won't be the cause
enabling force tcp mode
turning off quality of service
Constantly asking around
Generating a valid certificate
Connecting to servers not running the default port which does work

The server I'm trying to connect to is which uses the default port (not sure if it being under a domain makes a difference I'm fairly certain it wouldn't.)

if anyone wants to see the error for themselves I made this video a while back running on linux mint xfce:

if anyone can help me I'll be thankful to you forever, I really need to be able to connect to mumble!