Results of Mumbletesting

McFly
2008-01-22
2012-10-30
  • McFly

    McFly - 2008-01-22

    Hi everybody,
    i know the topicname ist not that good, but:

    We did our first test with mumble with around 32 Player playing a Battle in BF2.
    Serval small problems occurs, which i want write here. I know the most failuredescriptions are horrible for an developer. :(
    So, how can i get more debug information to provide it to you?

    • Overlay disappaers after a short time (not all clients)
    • After 10 seconds mumble quits with: "dxaudiooutputplayer: createsoundbuffer (Secondary): 0x88780032"
      Solved with selecting not "default directsounddevice" but "Soundcard direct" (You know what i mean ;) )
    • After using "moving" or "switching" between channels (or using Parentchannel or Subchannel Speak) Mumble dis not respond anymore to userinput.
      Sounds still worked but Mumble stands with near 100% CPU-Performance.
    • Instable Sound with my Xi-Fi (much scatter). But i was not the latest Driverversion. I will test with the latest version later.
    • Some people had echo on there voice if another player was "sendactive". The echodelay was too short for a coupling effect via an headset or speaker.
      I sound like the player are in an old dungeon :) Serval changes with the Soundparameter didn't help.

    That was it. For me to repeat.
    I know that such "error messages" are not so valueable fot the devs. But i want to help make Mumble a bit better.
    The Mumbles works again an murmur from the svn (with the link restore fix).

    Ah, a word to Vista:
    Does Mumble store it's settings in the programmdirectory? In Vista i have problems to store serverbookmarks. It's may be better to store the information in the /Users dirtree. When i rum Mumble as Admin on Vista, there is no problem.

    So, that enough text for the moment.
    Sorry for all people to bother you. Even if you have kept up to here. ;)

    cu...

     
    • McFly

      McFly - 2008-01-22

      If you want to test yourself at our server. No problem. Is in this forum an feature like "private messages" to provide you with the server data?

      cu...

       
    • Thorvald Natvig

      Thorvald Natvig - 2008-01-22

      The overlay only works well if you do not have other overlay-enabled programs. Known problem sources are XFire, Steam and fraps, and there are probably more.

      For #2 (the parentspeak): Is this repeatable?

      Turn the output latency up if you have scatter; it means your machine is overloaded and unable to keep up with the load you're giving it, so you simply have to increase the buffering.

      The echo is a know audiodriver bug, and it's especially common for users with AC97 audiocards who never bothered to update their audio drivers. Have them update their drivers and this should go away.

      Yes, Mumble stores settings in the program directory. There are other things that need to be tweaked a bit for Vista, but so far my development platform is still WinXP.

       
    • Sascha Jüngling

      "- After using "moving" or "switching" between channels (or using Parentchannel or Subchannel Speak) Mumble dis not respond anymore to userinput.
      Sounds still worked but Mumble stands with near 100% CPU-Performance. "

      That sounds a bit like the issue I had. Whenever I drag & dropped any channel on that channel's parent channel, mumble hung and used up 100% CPU. But this was in 1.1.1 and I THINK slicer fixed it. Actually, I am not sure. I remember that I sent slicer a backtrace, but he never told me if he found the cause :P

       
      • Pilot_51

        Pilot_51 - 2008-01-24

        I just checked and that problem still exists. I never knew about it before.
        I've been having another 100% CPU lockup problem that's been occurring. It appears to be randomly and somewhat rarely triggered when they join a channel, the logs show nothing else happening during the period that I see frozen on the client.

         
        • Pilot_51

          Pilot_51 - 2008-01-24

          By "they", I mean users on the server, unregistered users to be specific since they're the only ones that have triggered it.

           

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks