#989 setting suggestversion via ICE requires bitmasked version instead of "1.2.4"

1.2.5
accepted
nobody
None
1.2.4
5
2013-05-30
2013-05-30
No

In order to set a suggestversion using ICE you have to set it to the bitmasked version.

For example, to set as 1.2.5 via ICE you need to actually set "66053"

(1 << 16) + (2 << 8) + 5
=> 66053

The mumble.ini expects "1.2.5" which makes it confusing between setting via ICE and setting via the ini.

Discussion

  • Kissaki

    Kissaki - 2013-05-30
    • status: open --> accepted
    • Targeted Release: unspecified --> 1.2.5