#832 Compilation error on Fedora 16 : ‘CELT_SET_VBR_RATE’ was no

Current_GIT
closed
nobody
Mumble (544)
5
2012-12-25
2011-10-08
Paul Ezvan
No

Hi folks,

I am trying to compile Mumble on Fedora 16 but without success.

I've tried last stable tarball and git master branch.

At each time I get this error :

AudioInput.cpp:721:69: erreur: ‘CELT_SET_VBR_RATE’ was not declared in this scope
compilation terminated due to -Wfatal-errors.

How can I handle it ?

Thanks.

Discussion

  • Benjamin Jemlich

    Try to compile it with CONFIG+=bundled-celt.
    The problem is that we need the CELT 0.7.x header files to compile Mumble and Fedora doesn't have those (in /usr/include/celt).

     
  • Paul Ezvan

    Paul Ezvan - 2011-10-08

    Thanks.

    Using your advice I now get this error :

    ./G15LCDEngine_unix.h:38:30: erreur fatale: g15daemon_client.h : Aucun fichier ou dossier de ce type
    (The french error message means that the file is not found)

    How can I handle this ?

    Thanks for your help.

     
  • Natenom

    Natenom - 2012-12-25
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks