Multivalent tool pdf decryption problem!

Tools
rm260374
2004-12-10
2013-04-29
  • rm260374

    rm260374 - 2004-12-10

    Hi,
    I downloaded the last release of Multivalent Tool.
    I was interesting to Encrypt/Decrypt process on PDF files.

    The Encryption works good.
    I tried the following command:
        java -cp ".;C:\Prodotti\Multivalent20040415.jar" tool.pdf.Encrypt -user rinorocco -owner rino -password rino -inplace C:\PDF\pippo.pdf

    But the Decryption process doesn't work!
    I tried the following command:   
        java -cp ".;C:\Prodotti\Multivalent20040415.jar" tool.pdf.Decrypt -password rino  -inplace C:\PDF\pippo.pdf

    ...and the following is the error...

        C:\PDF\pippo.pdf: java.io.IOException: decrypt first!
        java.io.IOException: decrypt first!
            at multivalent.std.adaptor.pdf.PDFReader.getCatalog(PDFReader.java:990)
            at multivalent.std.adaptor.pdf.PDFWriter.<init>(PDFWriter.java:231)
            at multivalent.std.adaptor.pdf.PDFWriter.<init>(PDFWriter.java:207)
            at multivalent.std.adaptor.pdf.PDFWriter.<init>(PDFWriter.java:200)
            at tool.pdf.Decrypt.decrypt(Decrypt.java:66)
            at tool.pdf.Decrypt.decrypt(Decrypt.java:55)
            at tool.pdf.Decrypt.main(Decrypt.java:138)
               
    What i made wrong?
    Can someone help me?
    Thanks in advance.
    Rocco.

     
    • Tom Phelps

      Tom Phelps - 2004-12-13

      This looks like a bug in the current version, which has been fixed in my development sources and will be available soon in the next release.  However, without a test PDF, as requested on the Bugs and Support page, I can't be certain.  In the future, please post bugs to the bug tracker area.

       
    • lmehai

      lmehai - 2006-06-09

      Could you provide a java code how to use tool.pdf.Merge API to merge a list of files?

      Thanks for your help

       
    • Tom Phelps

      Tom Phelps - 2006-06-13

      There is documentation of all tools at multivalent.sourceforge.net.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks