#27 Will msys2 have `pexports' ported?

1.0
closed
Alexx83
None
2015-06-03
2014-03-06
LiTuX
No

Hello there. I've been using msys&mingw for years, and move to msys2&mingw-w64 last year. In msys&mingw, there's a tool named `pexports', which can obtain def file from dll, then with dlltool, there's a way to work with a single dll file without loading the functions by hand. Will this utility be ported to msys2? I think it will be great helpful.

Discussion

  • Alexx83

    Alexx83 - 2014-03-06

    You need install mingw-w64-i686-tools or mingw-w64-x86_64-tools and use "gendef" from this package.

    Regards,
    Alexey.

     
    Last edit: Alexx83 2014-03-06
  • Alexx83

    Alexx83 - 2014-03-06
    • assigned_to: Alexx83
     
  • Ray Donnelly

    Ray Donnelly - 2014-03-06

    gendef
    :-)

     
  • LiTuX

    LiTuX - 2014-03-07

    Seems great! I've heard about gendef before but never used it. :)

    BTW, for some reason, sometime I'd prefer a GUI debugger, for example, insight. Does there exist some tools like that?

     
  • Ray Donnelly

    Ray Donnelly - 2014-03-07

    Try qt-creator:

    pacman -S mingw64/mingw-w64-x86_64-qt-creator

    You need to go to 'Tools->Options' and setup 'Kits' comprising 'Compilers' and 'Debuggers', then you can use 'Debug->Start Debugging->Start and Debug External Application..'

     
  • LiTuX

    LiTuX - 2014-03-07

    I don't like an IDE, just a gdb front-end is enough.

     
  • Ray Donnelly

    Ray Donnelly - 2014-03-07

    Right, ignore all the IDE aspects of qt-creator that don't overlap with debugging then. To the best of my knowledge there are no decent GDB frontends these days; probably because most people don't share your IDE aversion.

     
  • Alexx83

    Alexx83 - 2014-03-11

    LiTuX, I can upload in my git repository PKGBUILD for Insight based on gdb-7.6. But it need to be fixed to build with tcl/tk 8.6.
    If you interested in it and can fix it then write me.

    Regards,
    Alexey.

     
  • Alexx83

    Alexx83 - 2014-03-13

    I'm add insight package and scripts for building it based on GDB-7.7. It building fine but need some old tcl/tk components to start like: Itcl-3.3, Itk-3.3, Iwidgets and some others. I don't have any time to see how fix it. Feel free to resolve it and send patches.

    Regards,
    Alexey.

     
  • Alexx83

    Alexx83 - 2014-03-13
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks