windows 7 TI usb FET tool

Help
david
2010-12-21
2013-03-06
  • david

    david - 2010-12-21

    Hi,
    I have not been able to get the TI msp430 FET USB FET tool to work with the  Windows 7  interface. I downloaded the latest release of mspgcc.  I run the msp430 gdbproxy and receive  the error “Could not initialize the device”. The usb FET tool works with TI’s  code composer so I know the FET is OK. Is the TI usb fet tool  (MSP-430UIF) supported under windows 7? I had the parallel port programmer and it worked fine under XP.

    Thanks,
    david

     
  • Randall Young

    Randall Young - 2010-12-21

    You may need to downgrade the firmware to a previous version to have the tool chain work with the debugger. There is a specific command to make this happen from the command line.  Sorry been quite a while for me to work with this tool, but it is well worth the effort.
    R.

     
  • david

    david - 2010-12-21

    Thanks for the reply.
    I'm currently using mspgcc-20081230.  The driver (MSP430.dll) from TI is version 2.4.7.1  The driver (MSP430.dll)  in the mspgcc/bin directory is 2.3.1.0.
    Does anyone know where there are archived versions of MSP430.dll  and which one to use with the above version of mspgcc?
    Should I start a new thread??

     

Log in to post a comment.