msp430-gdb not running gdb.ini file

Help
m2fscomp
2004-03-26
2013-03-06
  • m2fscomp

    m2fscomp - 2004-03-26

    I am new to the MSP GCC tools. I've installed the tools on Windows XP pro. Everything seems to work well. I can communicate to my FET tool using msp430-gdb, if I type in the command:
    "target remote localhost:3333". I created a gdb.ini with this command in it, but for the life of me I can't get msp430-gdb to load it upon start-up. I've tried moving it to the current working directory, c:\, bin directory, etc. Does anyone know where gdb is looking for this file? Thanks!!

     
    • Larry Young

      Larry Young - 2004-03-26

      On my system the msp430-gdb.exe initialization settings are saved in the file "gdbtk.ini" located in "c:\documents and settings\[user-name]".  I found this by experiment, not by any documentation.  I don't know which route to the Windows garbage pit called Docs&Settings is followed.  The ini file should be created when you run the debugger and it should save your session settings.  After that you can modify entries in the ini file with any text editor.

       
      • m2fscomp

        m2fscomp - 2004-03-27

        Thank you for the reply. I tried your suggestion. No luck. How did you get the init settings to save from gdb? Perhaps I could do the save and then attempt to find the new .ini file created.

         
        • Larry Young

          Larry Young - 2004-03-27

          When I run msp430-gdb with no gdbtk.ini file it displays the source window.  When I close that window a gdbtk.ini file is created and saved in the Doc&Set/user folder.   I don't believe that I did anything during setup to provoke that behavior.  If you think it would help to have a sample file, email me through SourceForge.

           
          • m2fscomp

            m2fscomp - 2004-03-27

            I tried starting msp430-gdb and then quitting. I search the hard drives, and I see no new .ini file of any sort. I have found that I can cause gdb to execute a file with the -x command:
            msp430-gdb -x gdb.ini ...
            I can live with this, though it would be nice to know why gdb won't read its .ini file as documented. I will try to file a bug report.

             
    • Hugh Hartwig

      Hugh Hartwig - 2008-10-09

      Are you using Cygwin to run msp430-gdb?  I placed my gdb.ini file in the /home/[user-name]/ directory.  In my case it was c:\cygwin\home\hugh\gdb.ini.  The username will be based on your windows login.  I ran into trouble because my username had a space in it.   If this happens, you may need to create a new windows login without spaces.  There were some hoops to get this working as well, but I don't recall what they were at the moment.

      Hugh

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks