#278 LDAP not working need help

None
open
nobody
1
2017-02-21
2012-09-18
Anonymous
No

thanks for MRBS. i am not a PHP person.

I have installed MRBS with XAMPP.

I am getting this error when trying to log into mrbs. useing AD user.
ERROR: PHP's 'ldap' extension is not installed/enabled. Please check your MRBS and web server configuration.
My Config.inn.php setting as below.

/*******************
 * Database settings
 ******************/
// Which database system: "pgsql"=PostgreSQL, "mysql"=MySQL,
// "mysqli"=MySQL via the mysqli PHP extension
$dbsys = "mysql";
// Hostname of database server. For pgsql, can use "" instead of localhost
// to use Unix Domain Sockets instead of TCP/IP.
$db_host = "localhost";
// Database name:
$db_database = "mrbs";
// Database login user name:
$db_login = "root";
// Database login password:
$db_password = '';
// Prefix for table names.  This will allow multiple installations where only
// one database is available
$db_tbl_prefix = "mrbs_";
// Uncomment this to NOT use PHP persistent (pooled) database connections:
// $db_nopersist = 1;
//$auth ["session"] = "php";
$auth ["type"] = "ldap";
$ldap_host = "172.21.2.2";
$ldap_port = 389;
$ldap_v3 = true;
$ldap_tls = false;
$ldap_base_dn = "OU=Students,DC=xxxxxx,DC=xxx";
$ldap_user_attrib = "xxx2012";
$ldap_dn_search_attrib = "xxx2012";
$ldap_debug = true;
$ldap_disable_referrals = TRUE;

Discussion

  • Campbell Morrison

    You need to enable LDAP support in your PHP installation, usually done by uncommenting the line

    Extension=ldap within your PHP.ini file

    Campbell

    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -6,7 +6,7 @@
     ERROR: PHP's 'ldap' extension is not installed/enabled. Please check your MRBS and web server configuration.
     My Config.inn.php setting as below.
    
    -
    +~~~~~~
     /*******************
      * Database settings
      ******************/
    @@ -38,3 +38,4 @@
     $ldap_dn_search_attrib = "xxx2012";
     $ldap_debug = true;
     $ldap_disable_referrals = TRUE;
    +~~~~~~
    
    • milestone: -->
     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-09-18

    Thanks for your replay...

    i have done the uncommenting the line in php.ini in C:\xampp\php folder. as below till the same error i am getting.

    extension=php_ldap.dll

    Mohan

     
  • Campbell Morrison

    Have you restarted XAMPP?

    Campbell

     
    Last edit: Campbell Morrison 2012-09-18
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2012-09-21

    Hi Campbell,

    I have restarted system also after changes in php.ini.

    still i am getting "ERROR: PHP's 'ldap' extension is not installed/enabled. Please check your MRBS and web server configuration."

    Mohan

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2016-02-16

    have you sloved ? I have this same problem.

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2016-02-17

    your error libsasl.dll is missing? if I am correct, then you need to copy libsasl.dll from php folder to the apache folder

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2016-09-21

    i have downloaded the mrbs from sourceforge.net and also Xampp and follwed all the steps correctly.. But wen i open localhost/mrbs/web it is not navigating to the mrbs page.. Can u pls help me in this.
    thanks in advance

     
  • Comment has been marked as spam. 
    Undo

    You can see all pending comments posted by this user  here

    Anonymous - 2017-02-21

    After configure LDAP into /web/config.inc.php/ this error is coming please help

    ERROR:

    Whoops! Unfortunately MRBS has encountered a fatal error. Please consult your system administrator.

     
  • Campbell Morrison

    If you are running MRBS 1.6.0 then please note this problem.

    If after applying the fix you are still getting a fatal error, then have a look in your error log for messages giving more detail.

     


Anonymous

Cancel  Add attachments





Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks