#20 compile error

closed-fixed
5
2007-11-26
2007-10-08
Anonymous
No

Could not compile on Fedora Core 6, x86-64:

Bad value for found architecture:
[root@ogre mplayerxp]# make
gcc -c -O4 -march=x86_64 -pipe -ffast-math -fomit-frame-pointer -W -Wall -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D__USE_FILE_OFFSET64 -D__USE_LARGEFILE -D_LARGEFILE64_SOURCE -Ilibmpdemux -Ilibvo -I/usr/include/dvdnav -Wall -o mplayer.o mplayer.c
mplayer.c:1: error: bad value (x86_64) for -march= switch
mplayer.c:1: error: bad value (x86_64) for -mtune= switch
make: *** [mplayer.o] Error 1

scott

Discussion

  • Nobody/Anonymous

    configure.log

     
    Attachments
  • sfrase6

    sfrase6 - 2007-10-08

    Logged In: YES
    user_id=1907920
    Originator: NO

    Sorry, thought I was logged in when I submitted this bug.

    sfrase6 is the user who submitted.

    Is there a workaround for this one? I tried all sorts of combinations for --target. But since there is no documentation on the valid inputs, all my make's failed with variants of the above error.

    Again, I am on 64-bit Fedora Core 6. I'd really like to get this working, as mplayer is choking when it tries to display my HDV content using only one of my eight 1.6Ghz processors. I have a Dell SC1430, dual quad core.
    ;)
    please help,
    scott

     
  • Anonymous - 2007-11-24
    • assigned_to: nobody --> nickols_k
    • status: open --> open-accepted
     
  • Anonymous - 2007-11-26

    Logged In: YES
    user_id=5556
    Originator: NO

    Fixed in CVS

     
  • Anonymous - 2007-11-26
    • status: open-accepted --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks