mplayer-plugin doesn't compile on Opensuse 11

Help
user100
2008-05-24
2013-05-13
  • user100

    user100 - 2008-05-24

    Hello,
    when I try to compile the mplayer-plugin for Firefox either with ./configure or
    with ./configure --with-gecko... I always get the following error:

    configure: error: xpidl compiler not found

    When I try to locate Xpidl I find it at:

    LinuxEther: # updatedb
    LinuxEther: # locate xpidl
    /usr/lib/xulrunner-1.8.1.14/xpidl
    /usr/lib/xulrunner-1.9.0/xpidl

    Under 10.3 it works without problems.

    Any help would be appreciated.

    Matthias

     
    • Kevin DeKorte

      Kevin DeKorte - 2008-05-24

      Give CVS a try... it should be working correctly. If it does not, it might be due to a .pc file problem. So if you could post the entire output of configure that should start pointing us in the right direction.

       
    • user100

      user100 - 2008-05-24

      Tried CVS, still have the same problem

      ./configure output:

      LinuxEther:~/Desktop/mplayerplug-in> ./configure
      checking for g++... g++
      checking for C++ compiler default output file name... a.out
      checking whether the C++ compiler works... yes
      checking whether we are cross compiling... no
      checking for suffix of executables...
      checking for suffix of object files... o
      checking whether we are using the GNU C++ compiler... yes
      checking whether g++ accepts -g... yes
      checking for gcc... gcc
      checking whether we are using the GNU C compiler... yes
      checking whether gcc accepts -g... yes
      checking for gcc option to accept ISO C89... none needed
      checking for a BSD-compatible install... /usr/bin/install -c
      checking for gawk... gawk
      checking whether make sets $(MAKE)... yes
      checking for pkg-config... /usr/bin/pkg-config
      checking pkg-config is at least version 0.9.0... yes
      configure: Determining mozilla/firefox packages to build against
      checking for MOZPLUG... yes
      checking for xpidl... no
      configure: error: xpidl compiler not found

      Hope it helps

       
      • Kevin DeKorte

        Kevin DeKorte - 2008-05-24

        try seeing if you have firefox-devel installed... it looks to me like you have multiple browser/xulrunner devel packages installed..

        So you might try removing a few. You also might check and see if there is premade packages for your distro. You also may want to see if gecko-mediaplayer is available. As that is the newer version of mplayerplug-in.

         
    • user100

      user100 - 2008-05-25

      Tried gecko-mediaplayer, it compiled without problems, mplayer-plugin still doesnt work. Thx for your help.

       
      • Kevin DeKorte

        Kevin DeKorte - 2008-05-25

        I made another change to mplayerplug-in that made it use the same plugin detection code as gecko-mediaplayer. So it should now compile.

         
    • user100

      user100 - 2008-05-25

      ./configure works now like a charm, but unfortunately I get a make error.

      Console output:

      LinuxEther:~/Desktop/mplayerplug-in> ./configure
      checking for g++... g++
      checking for C++ compiler default output file name... a.out
      checking whether the C++ compiler works... yes
      checking whether we are cross compiling... no
      checking for suffix of executables...
      checking for suffix of object files... o
      checking whether we are using the GNU C++ compiler... yes
      checking whether g++ accepts -g... yes
      checking for gcc... gcc
      checking whether we are using the GNU C compiler... yes
      checking whether gcc accepts -g... yes
      checking for gcc option to accept ISO C89... none needed
      checking for a BSD-compatible install... /usr/bin/install -c
      checking for gawk... gawk
      checking whether make sets $(MAKE)... yes
      configure: Determining mozilla/firefox packages to build against
      checking for pkg-config... /usr/bin/pkg-config
      checking for mozilla-plugin mozilla-xpcom... configure: WARNING: mozilla-plugin not found
      checking for firefox-plugin firefox-xpcom... configure: WARNING: firefox-plugin not found
      checking for seamonkey-plugin seamonkey-xpcom... configure: WARNING: seamonkey-plugin not found
      checking for xulrunner-plugin xulrunner-xpcom... configure: WARNING: xulrunner-plugin not found
      checking for libxul... yes
      checking MOZPLUG_CFLAGS... -fshort-wchar -I/usr/include/xulrunner-1.9.0/stable -I/usr/include/nspr4
      checking MOZPLUG_LIBS... -L/usr/lib/xulrunner-devel-1.9.0/lib -lxpcomglue_s -lxul -lxpcom -lplds4 -lplc4 -lnspr4 -lpthread -ldl
      checking for xpidl... /usr/lib/xulrunner-1.9/xpidl
      checking for gtk+-2.0... yes
      checking GTK_CFLAGS... -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12
      checking GTK_LIBS... -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
      checking for gtk+-2.0 >= 2.4.0... yes
      checking GTK24_CFLAGS... -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12
      checking GTK24_LIBS... -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
      checking for gthread-2.0... yes
      checking GTHREAD_CFLAGS... -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
      checking GTHREAD_LIBS... -pthread -lgthread-2.0 -lrt -lglib-2.0
      checking how to run the C preprocessor... gcc -E
      checking for x11... yes
      checking X_CFLAGS...
      checking X_LIBS... -lX11
      checking for xt... yes
      checking XT_CFLAGS...
      checking XT_LIBS... -lXt -lX11 -lSM -lICE
      checking for grep that handles long lines and -e... /usr/bin/grep
      checking for egrep... /usr/bin/grep -E
      checking for ANSI C header files... yes
      checking for sys/types.h... yes
      checking for sys/stat.h... yes
      checking for stdlib.h... yes
      checking for string.h... yes
      checking for memory.h... yes
      checking for strings.h... yes
      checking for inttypes.h... yes
      checking for stdint.h... yes
      checking for unistd.h... yes
      checking for xpm... yes
      checking XPM_CFLAGS...
      checking XPM_LIBS... -lXpm -lX11
      checking for ANSI C header files... (cached) yes
      checking stddef.h usability... yes
      checking stddef.h presence... yes
      checking for stddef.h... yes
      checking for stdlib.h... (cached) yes
      checking for unistd.h... (cached) yes
      checking for sys/stat.h... (cached) yes
      checking fcntl.h usability... yes
      checking fcntl.h presence... yes
      checking for fcntl.h... yes
      checking for an ANSI C-conforming const... yes
      checking whether time.h and sys/time.h may both be included... yes
      checking for pid_t... yes
      checking for size_t... yes
      checking for stdlib.h... (cached) yes
      checking for GNU libc compatible malloc... yes
      checking vfork.h usability... no
      checking vfork.h presence... no
      checking for vfork.h... no
      checking for fork... yes
      checking for vfork... yes
      checking for working fork... yes
      checking for working vfork... (cached) yes
      checking for memset... yes
      checking for strcasecmp... yes
      checking for strchr... yes
      checking for strdup... yes
      checking for strncasecmp... yes
      checking for strstr... yes
      checking for strrchr... yes
      checking for snprintf... yes
      checking for mkfifo... yes
      checking for dup2... yes
      checking for gettimeofday... yes
      checking for strerror... yes
      checking for strtol... yes
      checking for mkdir... yes
      checking for setlocale... yes
      checking for memmem... yes
      checking libintl.h usability... yes
      checking libintl.h presence... yes
      checking for libintl.h... yes
      checking sys/time.h usability... yes
      checking sys/time.h presence... yes
      checking for sys/time.h... yes
      checking sys/param.h usability... yes
      checking sys/param.h presence... yes
      checking for sys/param.h... yes
      checking locale.h usability... yes
      checking locale.h presence... yes
      checking for locale.h... yes
      checking for stdbool.h that conforms to C99... yes
      checking for _Bool... yes
      checking for sys/wait.h that is POSIX.1 compatible... yes
      checking return type of signal handlers... void
      checking for DPMSQueryExtension in -lXdpms... no
      checking for X11/extensions/dpms.h... yes
      configure: creating ./config.status
      config.status: creating Makefile
      config.status: WARNING:  Makefile.in seems to ignore the --datarootdir setting
      config.status: creating po/Makefile
      config.status: WARNING:  po/Makefile.in seems to ignore the --datarootdir setting
      config.status: creating install.sh
      config.status: WARNING:  install.sh.in seems to ignore the --datarootdir setting
      config.status: creating uninstall.sh
      config.status: creating dist.sh
      config.status: creating mplayerplug-in.spec
      config.status: creating config.h
      LinuxEther:~/Desktop/mplayerplug-in> make
      g++ -c -o plugin.o -Wall -DXP_UNIX -DMOZ_X11 -fshort-wchar -I/usr/include/xulrunner-1.9.0/stable -I/usr/include/nspr4   -I/usr/include/xulrunner-1.9.0 -g -O2      -g -O2  -Iinclude -fPIC  -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12   -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12   -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -DGTK_ENABLED   Source/plugin.cpp
      In file included from Source/nsScriptablePeer.h:48,
                       from Source/plugin.h:54,
                       from Source/plugin.cpp:37:
      Source/nsIScriptableMplayerPlugin.h:28:60: error: macro "NS_DEFINE_STATIC_IID_ACCESSOR" requires 2 arguments, but only 1 given
      Source/nsIScriptableMplayerPlugin.h:123:64: error: macro "NS_DEFINE_STATIC_IID_ACCESSOR" requires 2 arguments, but only 1 given
      In file included from Source/nsScriptablePeer.h:48,
                       from Source/plugin.h:54,
                       from Source/plugin.cpp:37:
      Source/nsIScriptableMplayerPlugin.h:28: error: ISO C++ forbids declaration of ‘NS_DEFINE_STATIC_IID_ACCESSOR’ with no type
      Source/nsIScriptableMplayerPlugin.h:31: error: expected ‘;’ before ‘virtual’
      Source/nsIScriptableMplayerPlugin.h:123: error: ISO C++ forbids declaration of ‘NS_DEFINE_STATIC_IID_ACCESSOR’ with no type
      Source/nsIScriptableMplayerPlugin.h:126: error: expected ‘;’ before ‘virtual’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::shutdown()’:
      Source/plugin.cpp:437: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:440: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::Play()’:
      Source/plugin.cpp:2241: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::Pause()’:
      Source/plugin.cpp:2271: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::Stop()’:
      Source/plugin.cpp:2291: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2293: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2303: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::Quit()’:
      Source/plugin.cpp:2321: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2322: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::FastForward()’:
      Source/plugin.cpp:2348: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2349: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2351: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::FastReverse()’:
      Source/plugin.cpp:2375: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2376: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2378: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::Seek(double)’:
      Source/plugin.cpp:2391: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp:2395: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::VolumeUp()’:
      Source/plugin.cpp:2409: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::VolumeDown()’:
      Source/plugin.cpp:2423: warning: deprecated conversion from string constant to ‘char*’
      Source/plugin.cpp: In member function ‘void nsPluginInstance::SetShowlogo(PRBool)’:
      Source/plugin.cpp:3151: warning: suggest explicit braces to avoid ambiguous ‘else’
      make: *** [plugin.o] Fehler 1

       
      • Kevin DeKorte

        Kevin DeKorte - 2008-05-25

        Try a 'make clean' or 'make distclean' and try it again.

         
    • user100

      user100 - 2008-05-26

      Worked!!! with 'make clean'.

       
  • Craig Harding

    Craig Harding - 2009-09-17

    I am having this problem also.

    I have checked out cvs today and I still get the xpidl is midding error. I was using 3.55 and then tried the daily tarball and then now I'm trying the CVS version.

    I've followed the install directions on the plugin install page. Perhaps I'm missing something, but I don't think so.

    Can you suggest anything else? Below is the output.

    ./configure -with-gecko-sdk ../../../src/gecko-sdk/
    configure: WARNING: you should use -build, -host, -target
    configure: WARNING: invalid host type: ../../../src/gecko-sdk/
    checking for ../../../src/gecko-sdk/-g++… no
    checking for ../../../src/gecko-sdk/-c++… no
    checking for ../../../src/gecko-sdk/-gpp… no
    checking for ../../../src/gecko-sdk/-aCC… no
    checking for ../../../src/gecko-sdk/-CC… no
    checking for ../../../src/gecko-sdk/-cxx… no
    checking for ../../../src/gecko-sdk/-cc++… no
    checking for ../../../src/gecko-sdk/-cl.exe… no
    checking for ../../../src/gecko-sdk/-FCC… no
    checking for ../../../src/gecko-sdk/-KCC… no
    checking for ../../../src/gecko-sdk/-RCC… no
    checking for ../../../src/gecko-sdk/-xlC_r… no
    checking for ../../../src/gecko-sdk/-xlC… no
    checking for g++… g++
    checking for C++ compiler default output file name… a.out
    checking whether the C++ compiler works… yes
    checking whether we are cross compiling… no
    checking for suffix of executables…
    checking for suffix of object files… o
    checking whether we are using the GNU C++ compiler… yes
    checking whether g++ accepts -g… yes
    checking for ../../../src/gecko-sdk/-gcc… no
    checking for gcc… gcc
    checking whether we are using the GNU C compiler… yes
    checking whether gcc accepts -g… yes
    checking for gcc option to accept ISO C89… none needed
    checking for a BSD-compatible install… /usr/bin/install -c
    checking for gawk… no
    checking for mawk… mawk
    checking whether make sets $(MAKE)… yes
    Using new (v1.7+) gecko-sdk
    checking for xpidl… no
    configure: error: xpidl compiler not found

     
  • Kevin DeKorte

    Kevin DeKorte - 2009-09-17

    I think you need to use an absolute path to gecko-sdk when you compile it. Also you may want to see if your distro provides a xulrunner-devel package. So you don't have to use the gecko-sdk option.

    Another option is to remove mplayerplug-in and install gecko-mediaplayer and gnome-mplayer

    http://kdekorte.blogspot.com/2007/02/mplayerplug-in-being-changed-to-gecko.html

     
  • Craig Harding

    Craig Harding - 2009-09-18

    I've gotten a little further.. I added the xpidl to my $PATH variable:

    export PATH=$PATH:/path/to/gecko/bin

    and tried recompiling but then I get this:

    …<br>
    configure: creating ./config.status<br>
    config.status: creating Makefile<br>
    config.status: WARNING:  'Makefile.in' seems to ignore the -datarootdir setting<br>
    config.status: creating po/Makefile<br>
    config.status: WARNING:  'po/Makefile.in' seems to ignore the -datarootdir setting<br>
    config.status: creating install.sh<br>
    config.status: WARNING:  'install.sh.in' seems to ignore the -datarootdir setting<br>
    config.status: creating uninstall.sh<br>
    config.status: creating dist.sh<br>
    config.status: creating mplayerplug-in.spec<br>
    config.status: creating config.h<br>
    config.status: config.h is unchanged<br>
    /home/charding/src/gecko-sdk/bin//xpidl -w -m header -I yes/idl -I Source -e Source/nsIScriptableMplayerPlugin.<br>
    h Source/nsIScriptableMplayerPlugin.idl<br>
    /home/charding/src/gecko-sdk/bin//xpidl: error while loading shared libraries: libIDL-0.6.so.0: cannot open sha<br>
    red object file: No such file or directory<br>

    I do have libIDL-dev installed but I don't have a libIDL-0.6.so.0 file, just a   /usr/lib/libIDL-2.so.0

    Any thoughts? Thanks for your earlier help. I did install the xulrunner-dev but that didn't help.

     
  • Kevin DeKorte

    Kevin DeKorte - 2009-09-18

    Probably need to set your LIBPATH variable to point to where gecko-sdk is. Since that file is probably there. I'm surprised it did not work with xulrunner-devel install as that usually just works.

     
  • Craig Harding

    Craig Harding - 2009-09-18

    I already checked that. That libIDL-0.6.so.0 file is not in the gecko directory.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks