mplayer and mozilla 1.3 problems

Help
2003-04-09
2003-04-16
  • Bob Hoffman

    Bob Hoffman - 2003-04-09

    I am losing my mind. Mplayer works fine from the command line. If I am using the browser and try to stream an .asf file (Yahoo news and video) I have two different situations:

    If I use mplayer as a helper application, I can watch the video but do not get any sound. 

    If I use the mplayerplug-in, I get sound but no video.

    If I play a local .asf file, everything is fine.

    Keep me out of the insane asylum, my insurance won't cover it.

     
    • Kevin DeKorte

      Kevin DeKorte - 2003-04-10

      Hum, that is really a strange issue. I'm a running RedHat 9, with mplayer (make sure you have the 0.90 release and not any pre or rc releases).

      Also, you may want to upload your mplayerplug-in.conf if you have one so that I can see it.

      Kevin

       
      • Bob Hoffman

        Bob Hoffman - 2003-04-11

        I looked in several obvious places then searched the entire computer and could not find a file mplayerplug-in.conf

        Is there an example file somewhere I can use?  I have been playing some more.  I can play a local file fine but if I do
        mplayer (some url) all I get is the video...
        it says cannot open audio  device or resource busy   but it works fine if I play a local file

        I am stumped

         
        • Kevin DeKorte

          Kevin DeKorte - 2003-04-11

          add ao=arts for KDE or ao=esd for GNOME to $HOME/.mplayer/config and see if that corrects your sound issues

           
          • Bob Hoffman

            Bob Hoffman - 2003-04-12

            tried every combination I could think of. Mplayer and mplayerplug-in play local files fine with audio and video but trying to play a clip from a url brings only video...I get a message that it cannot initialize sound device..

            ....but if it is a local file it works fine.

            I give.

             
            • Kevin DeKorte

              Kevin DeKorte - 2003-04-12

              Sounds like a problem you need to get resolved at the mplayer-user mailing list.  I have never heard of such of a problem with mplayer. Do you have specific examples that you could share so that I could take a look and maybe confirm the problem? Did you go thruough the "testing" portion of the HOWTO page? On the mplayerplug-in home page?

              Kevin

               
              • Bob Hoffman

                Bob Hoffman - 2003-04-12

                http://story.news.yahoo.com/news?tmpl=index2&cid=968

                click on any of these links and you will get a javascript window to choose media player or real player.

                if I click on the media player version, mplayer runs the video fine but no sound. If I paste it to the command line, same result.

                 
    • Kevin DeKorte

      Kevin DeKorte - 2003-04-16

      I do have some trouble with that site. I get sound but no video with Mozilla 1.3 on RH 9. Yahoo is sending a windows of size 1x336 for us to draw into. which is no good. The only work around I can find at this

      in mplayerplug-in.conf set
      fileonly-embed=0

      Kevin

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks