can not get mplayerplug-in to work. AAARRGGH!

  • t20racerman

    t20racerman - 2006-10-31

    Hi all

    I have now spent two days solid tryng to got this plug-in to work, but I have got nowhere.  It used to work in Firefox 1.5, but with 2.0 it doesn't.  However, I don't think it is a browser problem as such. I have firefox 2 running in a Suse 10.0 environment, but originally installed firefox 2 just into my user folder, so I was running firefox 1.5 as root, and firefox 2 as a user... and mplayer plug-in worked in root on firefox 1.5!

    Anyway, I uninstalled Firefox 1.5 with YaST.

    I then copied the folder 'firefox' from my user folder to /usr/local/

    I followed advice I found on Google and did the following:

    bash# cd /usr/local/bin
    bash# ln -s ../firefox/firefox .

    Now Firefox 2 was the default version for all users - as I wanted.

    However, no matter what I do I can't get the mplayer and some other plugins to work. I have worked on this problem for several hours now and no matter where i put the files, the mplayer (or Flash 10) plugin isn't recognised by Firefox.

    I have put the files

    mplayerplugin-so and
    mplayerplugin.xpt into the following folders:


    But still no good! Oddly though, the Adobe Flash version 9beta that I installed before i got into this mess still works fine - all YouTube videos play nicely with this.

    Why can't firefox find the plug-in???  If I go to a site that used to work lovely with mplayerplug-in such as:

    I just get the blank space on the page with the 'Click here to download plugin' message.  If I click on this, firefox tries to find the RealPlayer plugin, which I have installed but Firefox also can't find!

    If I type in  about:plugins to the firefox address bar, I get a long list of all the installed plug-ins (including mplayer and RealPlayer) but none of them work. 

    This problem is driving me mad.  I'm not a Linux expert, but have a reasonable understanding.

    • t20racerman

      t20racerman - 2006-10-31

      Oh,I forgot to mention, I have also put the mplayerplug-in.xpt file into every folder I can find called components!!  I even added a few new folders to see if this helped.

      • Kevin DeKorte

        Kevin DeKorte - 2006-10-31

        sounds like you have something all messed up...

        You might try opening "about:config" in firefox and finding the setting plugin.expose_full_path and set it to true and then go to about:plugins and see where the working flash plugin is installed and then drop all your plugins in there.. Make sure you copy them there and don't link them.

        You might also check permissions on the files and see if they are world readable.

        Firefox 2.0 is ok, it crashes a lot more on my FC5 box than 1.5 did. Perhaps you should wait for packman or someone else to package FF 2.0 for your distro and then install that.

    • t20racerman

      t20racerman - 2006-11-01

      Thanks for the reply.

      The setting plugin.expose_full_path is already set it true.  about:plugins gices the following:

      Shockwave Flash

          File name: /home/adrian/.mozilla/plugins/
          Shockwave Flash 9.0 d55

      gxine starter plugin

          File name: /usr/lib/gxine/
          will start external gxine media player for embedded media streams

      Default Plugin

          File name: /home/adrian/.mozilla/plugins/
          The default plugin handles plugin data for mimetypes and extensions that are not specified and facilitates downloading of new plugins.

      Adobe Reader 7.0

          File name: /usr/X11R6/lib/Acrobat7/Browser/intellinux/
          The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.

      Java(TM) Plug-in 1.4.2_11-b06

          File name: /usr/lib/jvm/java-1.4.2-sun-
          Java(TM) Plug-in 1.4.2_11

      mplayerplug-in 3.21

          File name: /home/adrian/.mozilla/plugins/
          mplayerplug-in 3.21

          Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
          JavaScript Enabled and Using GTK2 Widgets

      KDE Parts Plugin

          File name: /usr/lib/browser-plugins/
          A plugin which embedds KParts into a HTML page

      As you can see, the working Flash 9 plugin is in the same folder as the non-working mplayer one.  The flash one is a link though to another folder - does this matter?

      I have checked the permisions and the has ownership of user (me!).

      • Kevin DeKorte

        Kevin DeKorte - 2006-11-01

        Well for one you don't have the plugin completely installed. There should be 4 or 5 mplayerplug-in libraries.

        Couple of things..

        1. There is a package for Firefox 2 on Suse 10. I found one the other day, but can't find the link today

        2. Packman has mplayerplug-in. Install it from there.

        If you are unwilling to do that...

        Not much more I can help with other than to suggest what to delete. You might check the permissions of the ~/.mozilla/pluginreg.dat file. Maybe even delete it. This file is supposed to be regenerated when mozilla notices new plugins.

        What I would do... delete the pluginreg.dat file and all the mplayerplug-in files from your ~/.mozilla/plugins directory. Start up firefox and see what plugins you get. There should be no mplayerplug-in plugins listed. If not, find them and delete them and redo this paragraph until they are gone.

        Stop firefox, install the mplayerplug-in files (the .so files are the important ones, the .xpt files just enable javascript). Check about:plugins and see if you have several files loaded.

        If that does not work, then you will have to ask questions on the mozilla/firefox mailing lists.

    • t20racerman

      t20racerman - 2006-11-05

      Hi there

      I followed your suggestion of downloading an rpm package of Firefox 2 - in my case for Suse 10.0. Before doing this I renamed every firefox folder on the computer to firefoxold (easier to goback that way!). YaST happily installed Firefox 2 and it worked nicely.

      I checked about:plugins and the list of installed plugins was the same as before... however this time the mplayerplug-in worked!!

      I have no idea what difference installing Firefox again made, especially so as I didn't make any change to any of the plugin folders.  Anyway, it works now, so thanks for the help!

      All the best
      Adrian Baker


Log in to post a comment.