Mozilla 1.6 crashes w/mplayerplug-in-2.40

Help
Emmet Ford
2004-02-29
2004-04-14
  • Emmet Ford

    Emmet Ford - 2004-02-29

    When I attempt to load a video, Mozilla 1.6 crashes.

    I'm running:

    Slackware 9.1
    Gnome 2.4
    Linux 2.4.25
    Mozilla 1.6 (mozilla-1.6-xft-pc-linux.tar.bz2)
    MPlayer 1.0pre2-3.2.3 built from source
    mplayerplug-in-2.40 built with gecko-sdk-i686-pc-linux-gnu-1.6.

    My ~/.mplayer/config looks like this:

    vo=x11,xv
    ao=esd,arts,oss

    I've tried swapping xv & x11 in the above. I'm running Gnome so esd seems appropriate as the first value in the ao line.

    My ~/.mplayer/mplayerplug-in.conf looks like this:

    #debug=1
    #logfile=$HOME/mpp.log
    #vo=xv,x11
    #ao=arts,esd,oss
    #download=1
    #dload-dir=$HOME/tmp
    #keep-download=1
    noembed=1
    #cachesize=256
    #use-mimetypes=1
    enable-real=1
    enable-wm=1
    enable-qt=1
    enable-mpeg=1
    qt-speed=medium
    #rtsp-use-tcp=0

    I successfully ran all the mplayer tests detailed in the HOWTO. Pointing Mozilla 1.6 at http://www.apple.com/trailers/fox/daredevil/trailer_medium.html results in a Mozilla crash. Doing so from the shell generates this output:

    eford@baradur:~$ /usr/local/mozilla/mozilla

    Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'

    Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'
    Embedded mode
    Argument Name: pluginspage
    Argument Value: http://www.apple.com/quicktime/download/indext.html
    Argument Name: border
    Argument Value: 0
    Argument Name: bgcolor
    Argument Value: #000000
    Argument Name: type
    Argument Value: video/quicktime
    Argument Name: src
    Argument Value: http://a772.g.akamai.net/5/772/51/20b9f288dddd83/1a1a1aaa2198c627970773d80669d84574a8d80d3cb12453c02589f25382f668c9329e0375e8177dec6493f758ca2f93f86ed743/daredevil-tlr_320.mov
    Argument Name: target
    Argument Value: myself
    Argument Name: controller
    Argument Value: TRUE
    Argument Name: height
    Argument Value: 196
    Argument Name: width
    Argument Value: 320

    Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'
    New window! old: 0x0    new 0x2200018
    Size: 334 38 2200018
    Size: 320x196
    eford@baradur:~$

    Those Gtk-WARNING messages seem to be fairly chronic, which leads me to discount theor significance.

    Any help would be appreciated.

     
    • Kevin DeKorte

      Kevin DeKorte - 2004-03-03

      Looks to me like you are compiling the plugin in gtk2 mode and your browser is using gtk1 widgets. Try this

      ./configure --enable-gtk1 --with-gecko-sdk={path}
      make

      Then install it and see if that helps. Also you may want to get 2.45 it is more stable.

       
    • Emmet Ford

      Emmet Ford - 2004-03-05

      That did the trick. Thanks.

       
    • FireFerum

      FireFerum - 2004-04-14

      I have the same problem with mozilla 1.6 crashing. I have:

      Mandrake 10 default kernel
      Mplayer 1.0pre3.1.3
      mplayerplug-in 2.50
      Mozilla 1.6
      Firefox 0.8

      Mozilla, mplayer were both installed from rpm's that came with Mandrake 10. I'm not very experienced with Linux, but I have all the codecs in the right place, they show up only in the mozilla plugins but not firefox... I basically need a step by step on the install or what is wrong with it please. I also installed Netscape's newest version, but no plugins show up in there either... Thanks to anyone with directions on which way to go.

       
    • FireFerum

      FireFerum - 2004-04-14

      All right so I went to that page and followed all of those instructions. I configured it with gecko that i just downloaded and got the .so file and all in the right places. Now both mozilla and firefox show up the plugins when i start them. So, I went and tested them out. So far I only testes quick time, which had no sound but good picture, and windows media, which did not load but only showed the source call (html) for the particular page it was on. Thanks for at least making it not crash :) Now on to the sound.

       
      • FireFerum

        FireFerum - 2004-04-14

        I'm sorry to keep soamming the forum. I just wanted to say that the windows media did not work as it came from secured streams which is currently unsupported and has a few bugs. The sound is still not present but at least one of the issues has a resolve.

         
        • Kevin DeKorte

          Kevin DeKorte - 2004-04-14

          If you can send me a URL of a site that is not working I can work on resolving the issue.

           
      • Kevin DeKorte

        Kevin DeKorte - 2004-04-14

        To get sound with QuickTime 6 files, you need to make sure your version of mplayer is compiled with FAAD support. This is documented on the install page.

        Kevin

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks