Problem When Modifying mplayerplug-in.types

Help
2004-02-20
2004-03-03
  • Michael Aguirre

    Michael Aguirre - 2004-02-20

    I am running FC1 with mplayerplug-in 2.11, MPlayer 1.0pre3 and Mozilla Firefox 0.8.  A website that I often use to view videos has their MIME type for wmv files configured wrong (they are set as application/octet-stream).  I added the following line to the end of /etc/mplayerplug-in.types:

    application/octet-stream:wmv:Microsoft WMV video

    I put a trailing ; on the line before the one I added.  I then modified /etc/mplayerplug-in.conf by removing the # in front of use-mimetypes=1, renamed ~/.phoenix/pluginreg.dat and restarted Firefox.  The about:plugins page lists mplayerplug-in with all of the MIME types from the types file (including the one I added) and they are listed as enabled, but the plugin no longer plays ANY videos.  When I click on a mpg or avi that worked before, I am just prompted to save it to disk.  The misconfigured wmv files still don't play.

    I've reverted back to the default configuration and everything (but the wmv files on that particular site) is working again.  Why didn't this work?  I apologize if I have missed something obvious from the HOWTO.  Thank you.

    P.S.  I have asked them to configure the wmv files correctly, but it doesn't look like it's going to happen.

     
    • Kevin DeKorte

      Kevin DeKorte - 2004-03-03

      application/octet-stream I believe is a special type and this will cause you all kinds of problems. I have discussed this problem with the mozilla devel team and pretty much their response is to fix the website...

      Kevin

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks