CVS 09/04/04 mplayerplug-in & MPlayer CRASHS

  • ksandre

    ksandre - 2004-09-05

    Short very sad story:

    mplayerplug-in crashes with mozilla *every* time on *all* file types.  (It has pretty much always worked for me in the past, though started getting picky a couple of weeks ago.)  "crash" means completely disappears it, not just a freeze-up.

    System details:
    MPlayer-20040904 CVS
    MP extra codecs = all-20040809.tar.bz2

    MPlayer "configure" options:

    mplayerplug-in CVS [ChangeLog dated 09/03/04] begins:

            Fix case where browser hangs on MMS media being closed.
            Fix gtk warning: (gtk_widget_set_events): assertion `!GTK_WIDGET_REALIZE
    D (widget)' failed
            Reenable GTK2 widget destroy code
            Fix "Save" MMS stream from popup menu
            Fix "Save" when rename does not work, copy if needed
            Fix bug in fullyQualifyURL where url is of form :8080"

    alsa-*-1.0.6[a] (not in kernel & with oss-emu)
    Linux Kernel 2.4.26 (I know it is at *.27, but have not built it yet)

    stdin remainder:

    =====< BEGIN error >=====

    (==) Log file: "/var/log/XFree86.0.log", Time: Sat Sep  4 23:59:21 2004
    (==) Using config file: "/etc/X11/XF86Config"
    BScreen::BScreen: managing screen 0 using visual 0x23, depth 16
    (QFA)Talkback error: Can't initialize.

    Unknown Mozilla toolkit, assuming toolkit is GTK1
    This may cause Mozilla to crash. If it crashes recompile mplayerplug-in
    with a different toolkit.

    Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'

    Gtk-WARNING **: invalid cast from `GtkSuperWin' to `GtkWidget'

    Gtk-CRITICAL **: file gtkwidget.c: line 3824 (gtk_widget_set_events):
    `!GTK_WIDGET_REALIZED (widget)' failed.
    GetModeLine - scrn: 0 clock: 94500
    GetModeLine - hdsp: 1024 hbeg: 1072 hend: 1168 httl: 1376
                  vdsp: 768 vbeg: 769 vend: 772 vttl: 808 flags: 5
    /usr/local/lib/mozilla-1.7.2/mozilla/ line 72:   255
    Segmentation fault      "$prog" ${1+"$@"}

    =====< END error >=====

    The "Talkbask" error is puzzling, since this is supposedly a build without Talkback - or so I thought of that version in the past.

    The " line 72" error message is an enigma because line 72 in that script is blank, though the next line is "exitcode=0" - I use the "mozilla" script to start Mozilla, perhaps I should use "mozilla-bin" instead?

    mplayerplug-in "configure" options:


    Mozilla  and Gecko ares prebuilt package releases from  The mozilla "about:buildconfig" yields:

    =====< BEGIN >=====


    Build platform

    Build tools
    Compiler        Version         Compiler flags
    gcc     gcc version 3.2.3       -Wall -W -Wno-unused -Wpointer-arith
    -Wcast-align -Wno-long-long -pedantic -pthread -pipe
    c++     gcc version 3.2.3       -fno-rtti -fno-exceptions -Wall
    -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
    -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
    -fshort-wchar -pthread -pipe -I/usr/X11R6/include

    Configure arguments
    --disable-tests --enable-extensions=default,irc --without-system-nspr
    --without-system-jpeg --without-system-zlib --without-system-png
    --without-system-mng --disable-debug '--enable-optimize=-O2 -gstabs+'

    =====< END >=====

    I do notice this when I do "ldd" on <mozdir>/components/*.so: => not found
   => not found
   => not found
   => not found

    I tried much mplayerplug-in.conf tweakery to no avail (including none - ie., defaults only).

    I think that the problem may be with MPlayer because, although it does not crash from CLI, when it runs some clips (ie., some *.asf, *.wmv that I have always used for test successfully), it will look like a slide show rather than movie.  Other types may run very slow or out of sync (and yes, I do use those MP options to fix that).  It was all fine previously [last month, started to get wiggy around 08/22/04].  I never tried to use the *pre5 release because I had just a few days before the release built cvs.  (Plus I have almost always found CVS to work better.)

    In some cases, using "ao=oss" rather than "alsa" will help, but not always (like now).  I usually use a list of options for those entries anyway.

    There are no clues in /var/log/XFree*.log or other logs.

    Do you think if I get busy and build kernel 2.4.27 it would be  the charm?

    I noticed during my ALSA builds, I got "checking for RTC callback support in kernel... "no"" - I do have RTC enabled in my kernel.  Is this something different?  (I like the RTC timing in mplayer, it has worked well for me.)

    Well, anyway, I was very surprised to find that none of this worked anymore on my system.  The other recent changes have been the upgrade in Mozilla and ALSA.

    • ksandre

      ksandre - 2004-09-05

      ADDENDA to above [as if that excess was not enough, eh?]:

      You have on the mplayerplug-in Web site this under "install:"

      Compiling mplayer
      Compiling mplayer can be a tricky procedure, getting a premade package is recommended. Due to quirks in the compiler, machine optimizations, library dependancies and other things. The way I compile mplayer is the following

      get the ffmpeg source code
      in the ffmpeg source directory run the following command

      ./configure --enable-pp --enable-mp3lame --enable-faad --enable-a52 --enable-faac --enable-gpl

      Change to the mplayer source code directory and run the following commands

      rm -rf libavcodec
      rm -rf libavformat

      cp -r [ffmpeg source dir]/libavcodec .
      cp -r [ffmpeg source dir]/libavformat .

      ./configure --enable-win32
      sudo make install


      The INSTALL file for MPlayer says it is *not* necessary to copy the "libavcodec" if one uses the CVS *snapshot*, however it does not address the issue of "libavformat."

      I did neither ["libavcodec" is present, same dates as the one in the FFMpeg* CVS snapshot which I downloaded to look at].  There is NOT, howver, any "libavformat" directory.  Should I add that?  (I have no external encoding applications (ie., paranoia, lame, etc.) installed at this point anyway, as I am still learning and not near ready for that yet.)


      • Kevin DeKorte

        Kevin DeKorte - 2004-09-05

        First a couple of questions

        1. Did 2.66 work ok for you?
        2. Does the current CVS code work ok?
        3. As for the mplayer build steps... maybe you should ignore my instructions and use the ones at mplayer's home site. Libavformat probably does not exist anymore, it is just in my build scripts.

    • Kevin DeKorte

      Kevin DeKorte - 2004-09-05

      Also, are you POSITIVE that the version of mozilla you are using is using GTK1 widgets? You might try the script in the source  directory to see if you need gtk1 or gtk2 commands.

      The warning you are getting:
      Unknown Mozilla toolkit, assuming toolkit is GTK1
      This may cause Mozilla to crash. If it crashes recompile mplayerplug-inwith a different toolkit.

      Makes me wonder if the right toolkit is selected.

      I noticed that you are using current CVS.


    • ksandre

      ksandre - 2004-09-05

      Yes, "ldd mozilla-bin" shows Gtk1 enabled.
      (I saw NO Mozilla-1.7.2 builds with Gtk2 to try, btw.  I do have Gtk2 installed on my system.)

      Those *.sh scripts with mplayerplug-in do not work for me the "MOZ" part is the failure ("which" does not find Mozilla directory, even with the variables pre-set).

      I just tried now with the "--enable-x" options, but get the *same* results - no error output though (except the talkback error).  I found out that Talkback is supposedly enabled for ALL these builds.  There used to builds made without it. )

      Yes, I am using the CVS of the plugin current as of 09/03/04.

      I really think this has alot to do with MPlayer, as I said, though that toolkit error message problem has haunted me before (I posted a bit back about it).

      I would try with "--enable-gtk2" but as I said, there are no Mozilla-1.7.2 that have that that I can see at

    • ksandre

      ksandre - 2004-09-05

      Ooops.  Forgot.

      I found this thread on the MPlayer Users mailling list.

      This is something to explore for me.  I will rebuild MP using all those paths for the codecs that are affected by this "configuration" script.  (I just checked the MP CVS snapshot for today and that problem still exists.

      Here is the URL for the thread:

      (The seems to affect xanim and real as well at quick glance.)

      "[MPlayer-users] Documentation bug re win32 codecs"

    • ksandre

      ksandre - 2004-09-06

      kdekorte said:

      "Well I did do some gtk1 testing today on my firefox that is linked to gtk1 and it seemed to work well. Can you try the following...."

      I think there is no binary of FF with Gtk1 that I recall.  I am too timid to try to build either FF or Mozilla from source.  ;>

      The gecko-sdk you list above *is* the one I have been using.

      I see that I can not run that FF right now because "ldd" shows this:

      ./ /lib/ version `GLIBC_2.3' not found (required by ./
      ./ /lib/ version `GLIBC_2.3.2' not found (required by ./
      ./ /lib/ version `GLIBC_2.3' not found (required by ./
      ./ /lib/ version `GLIBC_2.3' not found (required by ./
      ./ /lib/ version `GLIBC_2.3' not found (required by ./
      ./ /lib/ version `GLIBC_2.3' not found (required by ./
      ./ /lib/ version `GLIBC_2.3' not found (required by ./

      As well as the absense of "" which is what the "Talkback" [QFA] in Mozilla-1.7.2 was looking for.  I settled that error by removing the two "qfa" parts from /mozilla/components/ and the ../components/talkback/ directory.  Otherwise, I get NO "ldd" errors with Mozilla-1.7.2.  It is too bad that Mozilla no longer has a build without the QFA.  I was under the impression I would be able to use FF when I downloaded it previously.  Oh well.

      Are you making mplayerplug-in now so that it will require both Gtk2 and gcc3+ and glibc > 2.3?

      I will try FF with my other Slackware [10.0] a bit later which is updated to those libs.  (I think.  It is gcc3+, etc.)
      Are the crashes I experienced related to dependencies in mplayerplug-in relating to these libs?  I did not see anything obvious in my build logs.

      Is the any conflict with the fact that MPlayer itself uses Gtk1 and NOT Gtk2?  (For the GUI anyway.  I do not have the GUI built in.)

      Just fiddled more with MPlayer alone and have found that something is pretty horked with some codecs.  This is expecially obvious with extensions *.asf and *.wmv.  Those are the ones that run as if they are slide shows not movies.  I am going to try rebuilding CVS again, if that does not improve, I suppose I will try the *pre5 release.

      Genrally, I would prefer to have only one browser on my  system, but I know I should retry FF (and Thunderbird).  I have not used it since it was called "Phoenix."  (I use Mozilla for mail.  I can not use Thunderbird until I fully migrate to Slackware-10.0 and the upgraded glibc.)

    • ksandre

      ksandre - 2004-09-08

      I reverted to mplayerplug-2.66 and no longer experience crashes with Mozilla.  MPlayer [CVS snapshot as of 09/07/04] is still running very slow and out-of-sync on most clips, with *.asf and *.wmv being the worst.  I tried to build *pre5 release, but it failed on "make' with an error related to Live libs, so I could not test the plug-in CVS with the MP *pre5 release.  :/

      • Kevin DeKorte

        Kevin DeKorte - 2004-09-08

        Running the current CVS version of mplayerplug-in via a debug session and then doing a bt when it crashes would be very helpful see your crash.

        To run a debug session start mozilla with the -g option and to do this you need a debugger installed and type run at the debug prompt. Then when mozilla crashes type bt and send me the results of that.

    • ksandre

      ksandre - 2004-09-10

      I will rebuild mplayerplug-in CVS and use debug when I have an MPlayer that is working correctly.  I just built MPlayer-20040910 so I will see how that goes first.  I am sure that my mine trouble lies with MPlayer at the moment.


Log in to post a comment.