can't Download videos (deliberate blocking?)

  • SilveRo

    SilveRo - 2005-10-05

    Before submitting a bug report, I wanted to see if other people have my same problem. I can view and save  videos from most sites, but from some I can't: the "Download" option doesn't appear. This happens with these videos, for example:

    Interestingly, the progress bar doesn't reach the end when the clip ends.

    This is one of the saved URLs:


    Once the URLs were different (they didn't have the "_!" and the "auth=..." parts). With these "addons", not even "mplayer -dumpstream ... -dumpfile ..." works.

    I wonder if this is deliberate, and if workarounds exist.

    THX!!!  =)

    • Kevin DeKorte

      Kevin DeKorte - 2005-10-05

      mms URL's CANNOT be saved, it is by design. Since many mms streams are transient and only exist at 1 point in time. mplayer is actually used to play the stream, so since it can play it you can probably capture it.

      You might try putting the url in quotes (") and using mencoder

      mencoder "URL" -o filename

      and see what that gives you. I'm sure there are mencoder options that work...

      I use something like this to make mp3 files from mms streams

      mplayer -ao pcm -aofile $2.pcm -vo null -cache 2048 "$1"
      lame $2.pcm $2.mp3
      rm $2.pcm

      The progress bar issue is a limitation of mplayer

      • SilveRo

        SilveRo - 2005-10-06

        THX for the reply and advice!

        I tried it with the "", like I did with mplayer, and I got the same error that I got with mplayer:

        silvero@mitsuki:~$ mencoder "mms://!/com/dailyshow/headlines/10126_headline.wmv?auth=caEaSdCb8axbFcZataGbYbMdZdscnbfbadG-bdrtYw-dHa-zFMxnC&aifp=ver_01" -o 10126_headline.wmv
        bash: !/com/dailyshow/headlines/10126_headline.wmv?auth=caEaSdCb8axbFcZataGbYbMdZdscnbfbadG-bdrtYw-dHa-zFMxnC&aifp=ver_01" -o 10126_headline.wmv: event not found

        I figured it's all because of the !, so I also tried putting \! instead of !, but doing that it just gives me the "Cannot open file/device." error, that I usually get when the URL is incorrect. I get this error both with and without the "?auth=..." part.

        The interesting thing, though, is that the "/_!" part in the url wasn't there before, and has been recently added.... every now and then they change the url (once they added a "/com" in the middle of the url).

        Maybe I should look for a program that does some kind of "screen video capture" (like a screenshot, but a video...).

        THX.  =)

    • klades

      klades - 2005-10-06

      Have you tried to put the escaped sequence "%21" instead of "!"?

      • SilveRo

        SilveRo - 2005-10-13

        >  Have you tried to put the escaped sequence "%21" instead of "!"?

        WOW !!!! THAT WORKED !!!!

        Man, I really appreciate it !!!!

        I hadn't thought of it at all ...

        THX AGAIN !!!


Log in to post a comment.