mplayerplug-in 1.1 install problem in FC1

Help
michaelbr
2004-01-20
2004-01-25
  • michaelbr

    michaelbr - 2004-01-20

    Hello:
    I just installed FC1 with Firebird 0.7, I downloaded mplayerplug-in 1.1 rpm for FC1 and installed without any problem, there's a file in /etc/mplayerplug-in.conf but I can't find the mplayerplug-in.so file, where this file is located? Is there a doc which tells you step by step how to install this plugin for Firebird? Sorry I'm new to this so please bear with me.

    Thanks in advance for any comment/suggestion.

     
    • Erich Edgar Hoover

      It's in the plugins folder for Mozilla (I believe it's /usr/lib/mozilla-1.4.1/plugins).  You need to copy the mplayerplug-in.so file into the Firebird plugins folder, which is: <place you extracted Firebird>/plugins.

      If you can't find the mozilla folder su root and go "updatedb" to update the database of files on your HD and then type "locate mozilla" or "locate mozilla-1.4.1" (1.4.1 is the version that comes with Fedora).

       
      • Kevin DeKorte

        Kevin DeKorte - 2004-01-21

        You can check where it goes with the command
        rpm -ql mplayerplug-in

        The plugin should be in /usr/lib/mozilla/plugins

        you can check the installed plug-ins in firebird by typing "about:plugins" in the location box.

         
    • michaelbr

      michaelbr - 2004-01-21

      Thanks so much for all of your replies, I found it and it's showing now in the Firebird's plugins, I'll just to test it to see if it's working, is there any site which you can test the plugins?

      Thanks

       
    • michaelbr

      michaelbr - 2004-01-22

      I tried to test the plugin but it doesn't work, I could see the plugin showing in the about:plugins but when I went to a web site with mpeg page to test it, it showed file being downloaded then nothing happened (just a blank page). Did I miss something?

      Thanks in advance for your comment/suggestion

       
      • Kevin DeKorte

        Kevin DeKorte - 2004-01-22

        did you follow the "HOWTO" on the webpage?

         
        • michaelbr

          michaelbr - 2004-01-22

          Sorry, I thought the mplayer is installed automatically, I'll install it then post the result.

          TIA

           
    • michaelbr

      michaelbr - 2004-01-23

      I followed the instructions in the HOWTO, downloaded the following files:

      lame-3.95.1-1.fr.i386.rpm
      mencoder-1.0pre3-1.i386.rpm
      mplayer-codecs-extralite-1.0-1.i386.rpm
      mplayer-common-1.0pre3-1.i386.rpm
      mplayer-gui-1.0pre3-1.i386.rpm
      mplayer-skin-default-1.0-2.noarch.rpm
      mplayer-vidix-1.0pre3-1.i386.rpm
      mplayer-vidix-radeon-1.0pre3-1.i386.rpm

      installed them using rpm according to instructions on the webpage, when I tried to test the player, got the following error:

      [kpu@d209-121-129-174 mplayer]$ gmplayer test.mov
      MPlayer 1.0pre3-RPM-3.2.2 (C) 2000-2003 MPlayer Team

      CPU: Advanced Micro Devices Athlon MP/XP/XP-M Barton 1833 MHz (Family: 6, Stepping: 0)
      Detected cache-line size is 64 bytes
      CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
      Compiled with Runtime CPU Detection - WARNING - this is not optimal!
      To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
      Reading config file /etc/mplayer/mplayer.conf
      Reading config file /home/kpu/.mplayer/config
      [cfg] read config file: /home/kpu/.mplayer/gui.conf
      Reading config file /home/kpu/.mplayer/gui.conf: No such file or directory
      vo: X11 running at 1024x768 with depth 24 and 32 bpp (":0.0" => local display)
      Reading /home/kpu/.mplayer/codecs.conf: Can't open '/home/kpu/.mplayer/codecs.conf': No such file or directory
      Reading /etc/mplayer/codecs.conf: 61 audio & 169 video codecs
      font: can't open file: /home/kpu/.mplayer/font/font.desc
      font: can't open file: /usr/share/mplayer/font/font.desc
      Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
      Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
      Using usleep() timing
      Can't open input config file /home/kpu/.mplayer/input.conf: No such file or directory
      Input config file /etc/mplayer/input.conf parsed: 53 binds

      MPlayer interrupted by signal 11 in module: unknown
      - MPlayer crashed by bad usage of CPU/FPU/RAM.
        Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
        disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
      - MPlayer crashed. This shouldn't happen.
        It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
        gcc version. If you think it's MPlayer's fault, please read
        DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
        won't help unless you provide this information when reporting a possible bug.

      - What was my mistake?
      - I only installed the gui one, not the command line one, do I need it?
      - the default skin version was older one 1.0-2, and the sample code was 1.6-3, does it matter?
      - in my $HOM#/.mplayer folder, I have only one config file, I don't have any other file (gui.conf, codec.conf, etc.), do I have to create it manually?

      TIA

       
      • Kevin DeKorte

        Kevin DeKorte - 2004-01-23

        Well you need to have mplayer on your disk, if you don't the plugin will not work.

        Make sure you do ALL the tests on the howto page. Where did you get the RPM's from?

         

Log in to post a comment.